Possible SATA III for SSD in Optibay !?

Discussion in 'MacBook Pro' started by ynewmarc, Jun 24, 2011.

  1. ynewmarc macrumors newbie

    Joined:
    Apr 3, 2011
    #1
    Hello,

    Read couple threads here, and look like what most people got is SATA II (3Gbps max) in Superdrive

    I just got an new 17 inch mbp 2011. I went to system profile and check there are two SATA III (6Gbps) for both intel chipsets (HDD and Superdrive as well) (see the pics below)

    So can anyone confirm that I can put my Curcial C300 SATA III SSD in optibay and it will negotiate at 6Gbps link speed?
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      87 KB
      Views:
      126
  2. bozz2006, Jun 24, 2011
    Last edited: Jun 24, 2011

    bozz2006 macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #2
    I have heard of many folks getting SATAIII in the optical bay. I think they're probably all shipping like that now. However, have not heard of anyone successfully running at SATAIII SSD in the optical bay.
     
  3. atMac macrumors 6502

    Joined:
    Jun 20, 2011
    #3
    There is an article some place (maybe OWC) saying that Only the 13in MacBook Pro will negotiate to 6GB/s in the optical bay. For some reason they could not get the 15 or 17in models to move faster than SATAII speeds.
     
  4. KJmoon117 macrumors 6502a

    Joined:
    Jun 10, 2007
    Location:
    NC
    #4
    Yes, there was an article like that.

    I think you should try it out and SEE if it works. But I highly doubt it would, you might get beach balls.

    Hell, it seems that A LOT of 17" MBP owners can't even get SATA 6Gbps to work in their main bay.
     
  5. ynewmarc thread starter macrumors newbie

    Joined:
    Apr 3, 2011
    #5
    If that true then too bad, the reason switching from 15inch 2009 to 17inch 2011 that my Curcial C300 can't get work with SATA II (EFI problem for 2009 model) and I have forced my SSD running SATA I.

    I will try tomorrow and see how it goes
     
  6. JasonH42 macrumors 6502

    Joined:
    Feb 9, 2010
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Mobile/8J2)

    The reality is much worse for 15" and 17" units with 6/6. I just bought a freshly built 15" with 6/6 and put a Vertex 3 in the optical bay. Whilst it does get recognised as being present it is completely unusable, files cannot be read at all. Directory listings appear eventually but then it's just beachballs and error messages. You don't get SATA II speeds, you get nothing.
     
  7. JasonH42 macrumors 6502

    Joined:
    Feb 9, 2010
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Mobile/8J2)

    Ynewmarc, I ran a C300 in a 2009 15" for 1yr+ with no issues at all. What was the problem with yours?
     
  8. KJmoon117 macrumors 6502a

    Joined:
    Jun 10, 2007
    Location:
    NC
    #8
    We're talking about only the 2011 MBP that's having issues at the moment. :S As that is the only model that has a SATA 6Gbps port.
     
  9. JasonH42 macrumors 6502

    Joined:
    Feb 9, 2010
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Mobile/8J2)

    Yes, to which I responded. He also said he had an issue with a C300 in a 2009 and I didn't hence curiosity. I wonder how many SSD issues reported are due to simple stuff not being done like SMC resets, setting startup disk etc.
     
  10. jonathanz macrumors newbie

    Joined:
    Jun 10, 2011
    #10
    I had the same experience as JasonH42. 15" MBP (2 weeks old) with 2.0 GHZ I7. I see the SSD in the optical bay and About this Mac tells me i've got 6GB (SATAIII), but in practice the drive was non-funcitonal. Couldn't partition, couldn't boot, nothing. SSD worked fine as an external, just not in the optical bay. Swapped it with the factory installed HDD and it works perfectly.

    I called OWC and they said that they had nothing official about why it didn't work, but i wasn't the only one and swapping was their suggestion.

    The HDD in the optical bay is now negotiating 3GB, even thought the chipset and Link Speed both show 6GB as possible.

    The SSD is the Mercury Extreme 6G 120GB.
     
  11. KJmoon117 macrumors 6502a

    Joined:
    Jun 10, 2007
    Location:
    NC
    #11
    Whoops my mistake >< I wasn't thinking properly.
     
  12. glasserp macrumors regular

    Joined:
    Apr 4, 2008
    Location:
    Detroit, MI
    #12
    FWIW I currently have a Crucial C300 64 GB as my boot drive in my optibay. No issues whatsoever right now (been about 3 days). Link speed is 3GB.
     
  13. Coburn macrumors newbie

    Coburn

    Joined:
    Mar 7, 2011
    #13
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_8 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8E401 Safari/6533.18.5)

    I wanted to keep my OWC Extreme in my optibay (for stock HDD benefitting from the HDD bay) - negotiated at 6gbps and everything - but when I would test the speeds with AJA, it was always really slow, and the wake from lid-closed sleep was slow. I switched the SSD into the hard drive bay and everything runs much smoother and I get those advertised speeds with AJA ;)
     
  14. doggiedoc, Jul 2, 2011
    Last edited: Jul 2, 2011

    doggiedoc macrumors newbie

    Joined:
    Jun 28, 2009
    #14
    I can confirm that the MCE Optibay enclosure for the Unibody MBPs appears to be noncompliant compliant* with SATA III. I have tested it with 2 different OCZ Vertex 3 SSDs and neither is recognized by the MBP in any way. I do not have access to any other SATA III drives to test so I can't completely rule out a firmware issue with the drive as the culprit. The Vertex 3s both work flawlessly in the HD bay and negotiate at 6GB.

    Today I emailed MCE hoping they have a SATA III compliant connector in the works.

    Doc


    EDIT:
    * I stand corrected.
    I've already received a response from MCE. (Great customer service!)

    So my issue appears to be either the Apple port implementation or the firmware on the Vertex 3.
     
  15. Timur macrumors 6502a

    Timur

    Joined:
    Oct 14, 2008
    #15
    Out of curiosity I put my Crucial M4 into a non OWC Optibay frame (aka DataDoubler) and noticed the following on bootcamped Windows:

    The M4 6G SSD is linked at 6G, but the link is very unstable. The Intel AHCI driver more or less instantly falls back to 3G once the drive is taxed (on the fly and stays there!) and the MSAHCI driver stalls several time until it falls back to PIO (can also be done manually and seems to still performs quite good with SSDs).

    Whether the bad 6G connection is caused by the Optibay frame (which is nothing more than a frame with 2 adapters + an internal cable anyway) or by the Macbook’s circuitry/cable I cannot say.

    Unfortunately I forgot to check if turning of WIFI and Bluetooth have any effect on Optibay connection quality. Both of these have their antennas around the Optibay area.

    BTW, OWC (who sell the "DataDoubler" Optibay frame) claim that it is an issue of the Macbooks.
     
  16. WiBu macrumors member

    Joined:
    Aug 10, 2010
    #16
    Just thought I should add my experience with the Optibay and a Vertex 3 (currently on firmware 2.06).

    I'm using a cheap eBay version of the Optibay (the nimitz one). When in the Optibay the Vertex 3 is recognised, but I'm unable to do anything with it. It attempts to negotiate at SATA3 speeds; I'm wondering if there is any way to force it to negotiate/work at SATA2 speeds? (Yes, I realise that it is limiting the potential of the drive and I would not run it in the Optibay full time, but it would be interesting to see what would happen, just because).
     
  17. samterm macrumors newbie

    Joined:
    Apr 5, 2012
    #17
    I successfully am running my SSD at SATA III 6Gb in the optical bay.

    There is nothing wrong with the optical bay running SATA III in the late 2011 Macbook Pro. If the the system profiler says that the Link Speed and Negotiated Speed are "6 Gigabit" then they probably are. That said, I think I am the first person to get reliable 6Gb SATA speeds in my optical bay. I have a walk through on my google site with the title: themacbookproproject.

    https://sites.google.com/site/themacbookproproject/

    And its not for the faint of heart.
     

Share This Page