Possible to run iBooks on 3.1.3?

Discussion in 'Jailbreaks and iOS Hacks' started by jlmitnick, Jun 23, 2010.

  1. jlmitnick macrumors regular

    Joined:
    Sep 22, 2009
    #1
    I was wondering if anyone knew of a way to run iBooks on 3.1.3. I'm on my 3GS at 3.1.3, jailbroken with Spirit, so I'm stuck here for now (I have old bootrom, but no SHSH to go back to 3.1.2 to pwn with something other than spirit).

    The ONLY feature that I really want from iOS 4 is iBooks, and that won't install on 3.1.3, but I don't want to upgrade (and lose my jailbreak) just for that, so is there some way to get iBooks to install on 3.1.3?
     
  2. enectrixx macrumors newbie

    Joined:
    Jun 25, 2010
    #2
    Yeah, I'm wondering about that too. I have an iPhone 3G and iOS4 runs so slow on it that i will reinstall 3.1.3 instead but I like iBooks so it would be nice if I could continue to use it. I haven't bought any books though, I just sync epub books from my computer so if there's any good alternative with a nice interface and features, either from Cydia or AppStore, then that would do.
     
  3. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #3
    I believe iBooks requires 4.0's version of the MobileSafari browser.
     
  4. Tu13es macrumors regular

    Joined:
    Sep 28, 2009
    #4
    Take a look at Stanza in the App Store.
     
  5. coocooforcocoap macrumors regular

    coocooforcocoap

    Joined:
    Sep 22, 2007
    Location:
    kathmandu, nepal
    #5
    yes Stanza is very cool, and the new kid is Kobo, which is also interesting. Free Agatha Christie!
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Nope, no ibooks for 3.1.3 or anything below 4.0
     
  7. nooficial macrumors newbie

    Joined:
    Sep 16, 2008
    #7
    I have modified Info.plist to work with 3.1.3 but it restarts, do not know if it is mixing something else. or impossible.
     
  8. yifanlu macrumors member

    Joined:
    Jul 29, 2009
    #8
    No. It's compiled with 4.0 Apis which has more features then 3.1.3. You can't do it without really major hacking. Like hybrid 3.1.3 4.0 os.
     

Share This Page