Possible wifi login bug on iOS 6?

Discussion in 'iOS 6' started by Imola Ghost, Feb 16, 2013.

  1. Imola Ghost, Feb 16, 2013
    Last edited: Feb 16, 2013

    Imola Ghost macrumors 65816

    Joined:
    Mar 21, 2009
    #1
    I travel a lot and some of the hotels require you to input a code to access the internet. For some reason I cannot browse wifi with this type of login requirement unless I turn on Airplane Mode.

    You can see in the photos below the actual steps I have to go thru to login to this wifi access point.

    1) Shows the error message when trying to login with wifi. This is before Airplane mode is turned on like you would normally log in on wifi. Most other times at similar hotels after you would select the wifi access point you would be take automatically to this log in page where you would enter a access code.

    2) This is showing what the wifi log on access page should look like but you can see the only way I can get this page is to turn on Airplane Mode.

    3) This showing that once I input my access code I'm granted access to the internet and this is the home page.

    4) Here you can see that I have wifi on along with Airplane Mode and it shows the wifi access point I'm connected to.




    I have tried numerous times over the last 1.5 months to get my iPhone 5 to connect to the hotel wifi. I have no problem connecting to the wifi on my 13" MBP or my Xbox 360, as a matter of fact I am connected right now on my MBP. I've tried turning my phone off/on and restoring iOS 6 without any luck and I'm currently on iOS 6.1. I stay at these hotels a lot over the year (7 months here) and before the iPhone 5 came out I had my iPhone 4 and was able to log in just fine as it was after I got my iPhone 5 I wasn't able to access the wifi.

    Ideas?
     

    Attached Files:

  2. michelborane macrumors newbie

    Joined:
    Apr 1, 2013
    Location:
    Palm Beach Lakes Blvd
    #2
    IOS 6.x is still breaking Wi-Fi for some Apple users.
     
  3. macandmercedes macrumors member

    Joined:
    Jan 10, 2013
    Location:
    New York
    #3
    Several Apple users who have upgraded their firmware version are facing the same problem.
     

Share This Page