Possibly the newest and most horrible error, and I got it, Help please?

Discussion in 'Jailbreaks and iOS Hacks' started by endor43, Sep 5, 2010.

  1. endor43 macrumors newbie

    Joined:
    Sep 5, 2010
    #1
    I have been jailbreaking since the iphone 3G, and I am stumped... Here's the deal, Its an Iphone 3GS 32GB 3.1.2 tooled by pwnage, SHSH blobs have been saved since forever, Its never touched water, rarely been dropped, It is not a "frozen apple logo", it is not the traditional "stuck at respring", I cannot restore using recovery or DFU.

    Here is what happened:

    I went to "changes" in Cydia, and updated what was there (nothing too important). At the end of the update, it asks me to "press to respring" (like normal), and then i press to respring.... except that right as i do that, the "Loading Changes" message box pops up. I say "sh**" because there is a possibility that my respring will get stuck, and it does. I sit and wait for about 30 min to see if it will kick itself out of the respring, it doesnt, so it reset (pressing home and sleep/wake).....

    Here is where it gets weird.

    I starts booting like normal, apple logo and all. But when the screen should leave the apple logo to normally finish booting, it doesnt. Instead it flashes black, and the apple logo reappears except that there are lines of pixelation at the top of the screen, and overlaying the apple logo, is the rotating respring wheel. The wheel rotates for about a minute ( sort of the time for a regular respring) then freezes.....

    So now my screen shows the apple logo, pixelation, and frozen respring wheel. It as such for about five min and then reboots, back to apple logo and above cycle starts all over again until it runs out of battery( which i have done), after a recharge it is the same.

    I tried recovery mode, but it will only even partially go to the recovery screen is i am in the frozen logo, moving wheel, pixelation state. It then flashes to recovery screen (Itunes logo with cable), but then after about 2.5 seconds, kicks out and reboots, starting the death cycle as described above. Recboot does no different.

    When I plug my iphone into the pc, without recovery or DFU it does not register, except for when i am in the frozen logo, moving wheel, pixelation state. It then shows up normally until the death cycle reaches the frozen logo frozen wheel, pixelation state at which time it no long er shows up in tunes, and is no longer visible in device manager (USB Disconnected) though it has not been unplugged. It will do this on and off at the aforemention place during the death cycle.

    It will not stay connected long enough to Sync, Update, Restore (to latest firmware, or previous firmwares both custom and official).

    DFU mode is the only mode that i can get the phone to stay in, and not kick itself out of. The huge problem is that within DFU, i also cannot get it to update, Restore. Update is greyed, and I have tried to restore to 3.1 custom, 3.1.2 official, 3.1.2 custom pwnage, 3.1.2 custom, 4.0.1 official, 4.0.2 official. Every time i try i get error, 1600,1604,2002,3914, maybe a few others.

    I have tried different USB ports and different usb ports on different computers.

    This "death cycle" has been endless except twice.

    The first time it happened, it was in death cycle, but then magically booted to safemode, I knew i only had two options, initiate fresh respring to exit safemode, or restore from safe mode(it was plugged in at the time)..... I initiated a new respring and f me , the deathcycle started all over again. so i was back to just trying futilely again and again to recreate the safemode thing, except for it couldnt.

    The second time it went to safemode was just as unexpected as the first. (it is not an issue of time. after the first time, i left in plugged in cycling through the death cycle overnight). I had tried to initiate new respring to no avail so i thought, better try to restore, so i did the update that seemed to me would most logically be free of any other problems, I just tried to update to the latest firmware.... Everything was going fine, until the phone go to the part where it would normally flash to the apple logo and progress bar.... but instead it flashed and restarted death cycle.

    and now i am out of ideas.

    I would really love it if some one could help me out. I have tried to be as thorough as possible in my explanation to make it easier for every one.

    I have contacted apple and told them that my phone was jsut frozen at apple logo and after a bit, they said that they would replace it (Ive had the phone less than a year), two problems with that: If it is 4.0.2, I cannot downgrade (no SHSH blobs for that new phone) now jailbreak. Or if i get lucky and its 4.0.1 or 4.0, then i can onyl jailbreak, and I am stuck with iOS4 which i had previously downgraded from back to 3.1.2, which is better than nothing, but not nearly as good as if the death cycle problem gets solved.

    Thank you so much for reading, I'd appreciate your help.

    Best,
    Endor43
     
  2. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #2
    I thought jailbreaking still voids the warranty. If so, you get no new iPhone.
    EDIT: and you wrote a LOT, so I skimmed this. Try tinyumbrela to get it out.
     
  3. esadb macrumors 65816

    esadb

    Joined:
    Nov 29, 2008
    #3
    Well you cant downgrade because Apple stopped signed old Fw's... You need recboot to kick the device out of DFU after you restore..
     
  4. endor43 thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #4
    Yes, but i dont think that they can get it out of death cycle, so they will never know... yes?

    Ive already tried recboot, also all the firmwares that i tried above 3.1 custom, would have been valid.
     
  5. Simm0nS777 macrumors 6502a

    Joined:
    Jul 15, 2010
    Location:
    Northeast Ohio
    #5
    The bolded happens to me on every restart. I thought it was normal after jailbreaking (just recently was my first time) apparently this is not normal? how can I fix it?
     
  6. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    The pixelated lines at the top of the reboot/respring screen are the jailbreak code @comex coded into the reboot. If jailbroken ,it will be there.
     
  7. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #7
    Pretty sure it is normal, I have a few I devices and it shows this on all them, and no issues.
     
  8. f4780y macrumors 6502

    f4780y

    Joined:
    Jul 21, 2009
    Location:
    Troon, Scotland
    #8
    The "pixelation" IS NORMAL. This is the jailbreak payload stored in the image buffer. It is NOTHING to be concerned about...
     
  9. endor43 thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #9
    Just for new reader, the lines of pixelation is NOT the problem, first post is. Thank you.
     
  10. f4780y macrumors 6502

    f4780y

    Joined:
    Jul 21, 2009
    Location:
    Troon, Scotland
    #10
    If you have been jailbreaking that long then hopefully you have been saving your SHSH's in Cydia by choosing "Make my life easier"???
    If so, then you simply need to redirect the firmware authorisation challenge to Saurik's servers and perform the DFU restore using 3.1.3, or whatever firmware you fancy, and it should work. There are tons of threads about how to do this...
     
  11. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #11
    I'm starting to think the tc didn't do this...
     
  12. endor43 thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #12
    Of course my SHSH blobs are saved. I have tried TinyUmbrella in DFU, i was only able to glean one from cydia, and that was in the the frozen logo, moving wheel, pixelation state. It gives me error 3014 when i try to restore to official 3.1.2 and 1600 when i try to restore to custom 3.1.2. Hosts file is right( it has the apple redirect to local), and internet connection is solid, no firewall, as far as i know i have as direct a connection to the net as possible.

    TC?
     
  13. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #13
    If you are still seeing the pixelation, you are NOT getting it in DFU mode.
     
  14. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #14
    Topic creator. And jesh thank god heh, I was really worried for ya there. And if your seeing pixilation you aren't in DFU.
     
  15. endor43 thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #15
    No no. I could only get my SHSH blob to tinyumbrell while in the pixelation state, and once it had it i went into DFU. I tried to make it clear above. I do know what DFU and such are.
     
  16. ulbador macrumors 68000

    ulbador

    Joined:
    Feb 11, 2010
    #16
    Ha, you are not in DFU. If you are getting the shsh to tinyumbrella you are in restore mode.
     
  17. endor43 thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #17
    no no no, I was in a totally different mode when i gleaned the shsh from cydia using tinyumbrella. I then went into DFU mode, from which i could no longer get my shsh if i wanted to. TinyUmbrella had it though and Itunes recognized my device as being in DFU. It was also registed under device manager in the apple mobile device USB driver properties details as DFU. Please guys, help.
    Thanks
     
  18. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #18
    Sounds like you were pwned JB and some how installed the Jailbreakme.com JB too. Is that correct? If, yes, wondering if the two messing everything up.

    Instead of directing to Cydia and run Tinyumbrella:
    1) Make sure you Iphone is detected.
    2) check "Advanced Options."
    3) In new window, under "Device / Version," select the firmware version you want to downgrade to.
    4) Click on "Save my SHSH." Pray Cydia has them. If you don't get an error, it has been saved onto your computer.
    5) Repeat to save other firmware hashes if you wish.
    6) Now, click on "Display SHSHs." It should listed all hashes you have saved on your computer and the firmware you can downgrade to.
    7) Start "TSS server," download firmware file somewhere (google) and restore through iTunes with that file.
    8) If you phone get stuck during restore, trying "Kick out of recovery..."'in Tinyumbrella.

    If above still fail and since you have old SHSH hashes saved, did you try official 4.0.2 firmware in recovery or DFU mode?
     
  19. ckong macrumors regular

    Joined:
    Nov 12, 2009
    #19
    I've just stumbled into this thread as I don't read MacRumors every day.

    It sounds like you have an endless respring/reboot issue. Is that right? The iPhone keeps respringing, and then after 10 minutes or so, reboots?

    If that's the case, don't panic. There may be a way out. I had a similar issue a whiles back and was able to fix it.

    The Problem:
    MobileSubstrate apparently launches stuff out of the iPhone's /Library/MobileSubstrate/DynamicLibraries directory. One of those files got corrupted was incompatible when I updated through Cydia. After that, the iPhone would constantly respring, and after 10 minutes reboot.

    The Solution:
    SSH was enabled on my iPhone. It's working even between respings (but not reboots). So...I had local access to the phone. Using WinSCP, I "moved" a bunch of suspect files out of the /Library/MobileSubstrate/DynamicLibraries directory to my C drive. Less than 10 minutes later, my iPhone rebooted and BAM!...the endless respring/reboot cycle stopped. With renewed confidence that I could get back in anytime, I moved the files back slowly (in pairs...one .dylib and one .plist file) until I found the problem. In retrospect, I could have simply SSH'd into the phone to do the same, but the 10-minute reboot cycle would've made typing all the commands a race.

    Reference:
    I found a very good article doing a google "iphone endless respring" search. A very good one was on BigBoss's site http://thebigboss.org/2009/06/22/sbsettings-30-1-repack. Although the article describes an old problem with a previous version of SBSettings (which wasn't the cause of my problem), the solution to it described in detail was what saved me. So...a very big thanks to BigBoss for that. One caveat though...in the article he recommends deleting the files from /Library/MobileSubstrate/DynamicLibraries. I recommend moving the files out, so you can put the good ones back later. Otherwise, you'll have to just reinstall all your MobileSubstrate add-ons afterwards (which may or may not be a good thing).

    Hope this helps, and good luck!
     
  20. endor43 thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #20
    This sounds sort of like my problem, and i would try it except for:
    1. I do not know my phone's ip.
    2. I have no way of getting it to connect to my wireless network ( i dont think it is set to auto connect to my WAN)

    I suppose if it did i could just get the ip off the wireless router's page

    Ill give it a try
     
  21. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #21
    FYI your not supposed to bump your own thread check the rules! ;)
     
  22. endor43 thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #22
    I Fixed it!!

    Thank you so much for your help. The reason tinyumbrell ws not working for me (3014 error) was that it was redirecting gs.apple.com to 127.0.0.1 not 74.208.105.171 (sauriks server). I started TSS server, and then modified the host file ( to circumvent tiny's auto modification of the file). and then it worked!

    Thanks again!

    Best,
    Endor43
     
  23. CBR900RR macrumors 6502a

    Joined:
    Oct 11, 2008
    Location:
    Middle of Pacific
    #23
    Can you use iphone iphonebrowser to get into the iphone's directory?
     

Share This Page