Posting Help: How to fix this ?

Discussion in 'Mac Basics and Help' started by a2jack, Apr 20, 2019.

  1. a2jack, Apr 20, 2019
    Last edited: Apr 20, 2019

    a2jack macrumors regular

    a2jack

    Joined:
    Feb 5, 2013
    #1
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    What KIND of file are you trying to post/attach?
     
  3. a2jack thread starter macrumors regular

    a2jack

    Joined:
    Feb 5, 2013
    #3
    Thank's for getting back Fishrrman.

    A good question. I don't know what file type this is.
    I just wrote it in Text edit and tried to post/drag it from my desk top.

    Every once in a while a photo will bounce and I get that same error message. I'm sure this is all pilot error on my part but I am stumped.

    Here's a screen shot of it of the post I tried. a2
     

    Attached Files:

  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    If you composed it in TextEdit, then it might be saved with the file extension:
    .txt (for plain text)
    or
    .rtf (rich text)

    So try adding either ".txt" or ".rtf" to the END of the file name, and then try attaching it again.

    Does this make a difference?
     
  5. a2jack thread starter macrumors regular

    a2jack

    Joined:
    Feb 5, 2013
    #5
    It worked, but requires an additional step to open it on this forum.

    I will go back into the Text Edit rules and see if i can clean it up. I seldom use TE and for some reason it was deleting the extension.

    Right on again Fishrrman. Thanks. a2
     

    Attached Files:

  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    Location:
    betwixt
    #6
  7. a2jack thread starter macrumors regular

    a2jack

    Joined:
    Feb 5, 2013
    #7
    Chown 33. Good info.

    But that Apple support Doc ,as usual, really clouds ones mind. LOL.

    It appears, if I want to run pix/or additions within a TE document I need to run in Rich text, but no box for rtf extension. Only shows plain text box.

    Won't belabor this TE thing. It seems way over- complex for what I wanted to do here. I'll just keep it for plain text notes. Thanks for the reply.
     
  8. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Temecula, CA
    #8
    Somewhat off-topic to OP, but has anyone else had issues with this since 10.14? No matter how I set this, TE will never automatically add the ".txt" extension when I save a new file like it used to.
     
  9. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #9
    Mugwumper...

    Have you:
    1. Opened TextEdit
    2. Gone to preferences/open and save
    3. Put a checkmark into "add .txt extension to plain text files
    ???

    Personal experience:
    Sometimes you just have to "add the extension" yourself.
    Yes, it's more work, but you just have to DO it.
    BUT...
    Make sure you add the RIGHT extension.
    For example, if you create a rich text file and use the ".txt" extension, things might not work properly...
     
  10. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Temecula, CA
    #10
    Yes, the checkmark is set to "add .txt". In previous versions, when I would go to save a new file, the pop-up would show
    "Untitled.txt" with Untitled highlighted in blue. Now, all I get is just "Untitled" without the ".txt". I've unchecked it, and rebooted, but no change. Then, re-check, and still no change. This seems to have started with Mojave, but can't remember if it started with .2, .3 or .4 upgrades

    So yeah, I've been adding it myself - but I'm lazy and trying to be more efficient. ;^) It takes FOREVER to type those 4 extra characters. ;^)

    Thanks!
     
  11. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #11
    FWIW - i just tried it with Mojave 10.4.3 and it seems to work fine

    That said, There is another check box that might be the cause? - see attached
     

    Attached Files:

  12. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Temecula, CA
    #12
    Thanks, Mikzn - but it, too, is already checked. :^(

    Obviously, this is not the end of the world if it doesn't work, just annoying.

    I've been poking around to see if there's another setting somewhere, but haven't found anything yet . . .
     
  13. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #13
    it's the littles things :mad: - lol

    you probably checked the finder prefs too? finder< preferences < Advanced < show all filename extensions ?

    If that's not it - hope you find it - lol
     
  14. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Temecula, CA
    #14
    Umm, apparently I didn't check the Finder prefs (egg on face). :^( That was indeed the fix - thank you!!!
     
  15. a2jack thread starter macrumors regular

    a2jack

    Joined:
    Feb 5, 2013
    #15
    mikzn: That was the fix for me too. LOL Thanks again. a2
     

Share This Page

14 April 20, 2019