Potential software bug with gps for 3g iphone?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by matrixpeanut, Jul 13, 2008.

  1. matrixpeanut macrumors newbie

    Joined:
    Jul 12, 2008
    #1
    Hey guys,

    So I got my 16gig black iphone today. Everything was working fine, internet, maps, even the gps, until this evening. Sometimes, when I tell maps to locate me, the thing uses the triangulation to triangulate me to close to houston, texas. Now I live on the east coast, so this thing is definetely off. Also, when it was in that stage, waiting a little while and pressing the locate me again did nothing--no retriangulation or the little blue gps point showing up, it was stuck in texas. I tried everything, from resetting the default settings to hard resets (holding down the button on top), but it just wouldnt go back. Sometimes, the little blue circle thing that spins also sits there for a long time spinning, never triangulating anything. The 3g internet still works, along with all the other apps that use the internet.

    Heres where it gets interesting.

    I decided to turn of the 3g and use edge only. That has worked perfectly every time so far--It triangulates correctly and gps point shows up. I also tried wifi and that too has worked every time. but when I turn 3g back on, sometimes it will work but then suddenly, it stops working again.

    Also, about once or twice, the 3g stops working all together(cant access internet on 3g or maps dont load). Again, I turn off and on the 3g in the settings and it starts working again. Im thinking that this is some sort of software bug since I have seen the triangulation problem on 2 other separate iphones (both 16gig blacks also btw). But this could also be some sort of major hardware problem too.

    Maybe others should try turning off and on 3g and trying with edge and 3g to see if triangulation works. As of right now, the triangulation and gps are both working for me.

    I have tried this inside and out and it makes no diff. Right now it is working inside, but sometimes it doesnt and the same for being outside. Also, one phone had apps and the other didnt, and both had problems, so i dont think it has to do with apps. Also, I have not tried the newer firmware on itunes yet.

    Also, Ive read that other people having this problem also triangulate to texas. Whats with that? is that some default location or is something off with att?

    Sorry for the long post but I just wanted to be detailed.
     
  2. gallinger macrumors regular

    Joined:
    Jul 19, 2006
    Location:
    Canada
    #2
    Im having a bit of the same problem, only GPS wont work at all when WIFI is turned on. and if WIFI is on but 3G is turned off, it will use triangulation. If Both WIFI AND 3G are ON, Neither GPS or Triangulation will work.

    Lets fix this problem!
     
  3. colinmack macrumors regular

    Joined:
    Feb 25, 2006
    #3
    Make that 3...

    Black 16gig phone...GPS has stopped working in Google Maps. Switching 3G/Edge/WiFi settings and resetting the device doesn't seem to help.
     

Share This Page