Power button acts like it is stuck on MBP

Discussion in 'MacBook Pro' started by puddinsnack, Dec 16, 2013.

  1. puddinsnack macrumors newbie

    Joined:
    Dec 16, 2013
    #1
    I have a Macbook Pro 8,2 that will not turn on when hitting power button but will turn on with SMC reset. As long as I move the mouse or hold down a key on the keyboard I can do anything on the machine. Around 5 seconds after I stop moving the mouse or stop holding down a key the machine will pop up a windows about shutting down then it will go down hard like I was holding down the power key. The power key itself is not physically stuck. Anyone ever seen this problem before or have any advice on how I can troubleshoot this problem?
     
  2. Miss Terri, Dec 16, 2013
    Last edited: Dec 16, 2013

    Miss Terri macrumors 6502

    Joined:
    Nov 11, 2010
    Location:
    US East Coast
    #2
    I just had a very similar problem start the other day! I did some searching and found some others, and theirs seemed to be caused/solved by one of the following things:

    1) One person who had a Mac with a "user removable" battery, removed the battery and that fixed the problem. Figured it was an old/bulging battery.

    2) One person had the top case replaced (keyboard).

    3) One or two people had a new logic board put in (they had a droplet of water implicated).

    On my computer, there is a history of odd/intermittent power button and up-arrow key behavior. Around a year ago, I shut the computer down and then could not get it started again. I took it to the "Genius bar" and they diagnosed it as a failed power button, and said the top case would have to be replaced. Well, I was traveling, and so could not wait (it would have taken days), so in the meantime I just always left it sleeping, and on the rare occasion I would have to re-start it, I would take off the back cover and "jumper" the two power pads (luckily the children's game "Operation" was big when I was a kid ;)).

    Around 8 months later, my computer just "died." I can't remember why right now, but I deduced it was probably the battery. It had been getting older and tireder. iFixit had none in stock, so I drove a couple of hours to an Apple store and had them replace it with a new one.

    Well... lo and behold when I got back home from that, not only did I have a new battery, but.... the power button worked perfectly again. Just like it had never failed :confused: On the other hand, the "up-arrow" key then seemed to randomly go nuts. Not that use it often. No, without my ever touching it my cursor would just fly up to the top of the page (or a web page would scroll up like mad) and I would have to tap hard/repeatedly on the down arrow key to get it to stop. This happens regularly but intermittently.

    A couple of weeks ago, I was again in a town with an Apple store, and I went into the genius bar to see if they could figure it out and I could have it repaired. (Of course it was not doing the crazy arrow thing at the time.) They tested and poked and prodded, but couldn't come up with anything for sure. And... they said "Well, maybe it is the logic board, or maybe it is the top case." Both of those are kind of serious/expensive, and it's not that I would mind replacing one of them, but I hate to just guess and do them both :eek: So ... I left the store somewhat dejectedly. I was hoping that my weird series of issues would give them an "Aha!" moment.

    Then, a week ago (yes, I'm finally getting to that part). I was working away on the computer (mid-2010 MBP 13", btw) when I paused to do something else. Out of the corner of my eye I caught the "Do you really want to shut down?" mini-menu that normally pops up when you hit the power button (not that one that pops up if you go to Apple menu --> shut down, that says "if you do nothing this computer will shut down in X seconds). And then the computer just shut down! That mini-menu is NOT supposed to shut down the computer unless you actively say "yes."

    I started back up and did some typing and it seemed fine, but then as soon as I stopped doing anything for five seconds... Bam! Mini-menu then immediate, unasked for, unapproved shutdown. This happened over and over. If I kept typing or moving my hand on the trackpad, it would not happen; but if I paused for five seconds... Bam! I Googled and found the above things, but no easy solution. The people whose threads I found had the same thing where if they kept it active it would not happen. If the mini-menu came up and I got to it RIGHT AWAY and clicked "cancel," that would also stop it... for that one time.... until I paused again...

    So, while it was shut down, I got my backup drives out and ready. Then I started up and ran a Time Machine backup. While that was going, I opened a text document and just kept typing "m" over and over to keep it from shutting down (while reading a book with the other hand :D). Then I did the same with a Super Duper backup.

    Next I reset the SMC controller.... that didn't help.

    I also pushed firmly on the Power button a number of times in case it was stuck or something. No change.

    Finally I was ready to hit the sack, and I decided to just "agree" the next time the mini-menu came up, and clicked the blue button (to okay the shut down). It shut down. Then I started it up again and.... all was normal! Hallelujah! It's been a week of heavy computer usage and it has not done it again since.

    I have no doubt there is still something flakey going on in there. If I could figure out whether it was the top case or the logic board (or something else), I would have the culprit replaced; but I don't want to just start throwing multiple expensive parts at it on a guess!

    So... maybe try agreeing with the mini-menu and confirm that "Why yes, I do in fact want to shut down; how did you know?", to at least see if that stops it for now. Or maybe someone here can answer both of our questions - that would rock.

    PS: I just noticed you said yours would not turn on unless you were manipulating keys. Mine didn't have that problem (it would power up with the button just fine), but I suspect that is only because, since I put in an SSD not too long ago, it starts up really fast. I'm thinking that if I was back with my old HDD, the time it would take to start up might mean that it would "need key stimulation" in order to not pop up the shut down mini-menu. That's just a guess though (but the other people I mentioned up top said the same thing as you - I don't think they had SSD's because those threads were mostly from a couple of years ago. Do you have an SSD? Or are you on "slow HDD boot" time?
     
  3. puddinsnack thread starter macrumors newbie

    Joined:
    Dec 16, 2013
    #3
    Do you have an SSD? Or are you on "slow HDD boot" time?[/QUOTE]

    I have a slow HDD. I do have a SSD that I can pop in and test with. When I get home I will try your agreement suggestion and see what happens. Thanks for all of your info.
     
  4. Miss Terri macrumors 6502

    Joined:
    Nov 11, 2010
    Location:
    US East Coast
    #4
    I'll be curious to hear what happens!

    I sure am liking the SSD in general. Really gave the ol' Core2Duo machine a boost (plus I had around 225GB on the original 250GB HDD - now I have 500GB).

    I did debate whether to even buy the SSD for a machine with a couple of quirks, but if I bought a new 13" MBP I wanted 16GB of RAM, and that's not available without waiting for weeks, so I went with the SSD on sale and put in in this MBP. Figured I could always find something to do with it if the MBP just died.

    Anyway, I'll keep an eye out to see if you post back.
     
  5. botosuki macrumors newbie

    Joined:
    Jul 22, 2015
    #5
    just wanted to post that I had the exact same problem:

    computer (mbpr 15" late 2013) would shut down like the power button was held down, unless I kept moving the cursor around. If I left it alone, the shut down prompt would pop up in about 6 seconds, then it would almost immediately power down.

    What solved it for me was a safe boot.
     

Share This Page