power from wall socket for external portable drive?

Discussion in 'Buying Tips and Advice' started by MrFusion, Oct 16, 2015.

  1. MrFusion macrumors 6502a

    Joined:
    Jun 8, 2005
    Location:
    West-Europe
    #1
    I am using a portable hard drive for time machine. But it's powered via USB. So every time my mac goes to sleep, the drive gets unmounted and OS X gets very upset.

    Is there a way to power my external drive from a wall socket? It only has a USB 3 connection.
     
  2. macs4nw macrumors 601

    macs4nw

    #2
    That's annoying, and that problem has been brought up here several times before. Powering your drive from the wall, even if that were possible, might not solve your problem, besides you wouldn't want your drive spinning 24/7.
    I suspect the drive unmounts because the Mac goes to sleep, rather than your external drive losing power. Afaik, the USB ports stay alive during sleep mode, but go dead only if you shut your computer down.

    Do you have 'Power Nap' enabled in Sys Pref > Energy Saver? Try to toggle that and see if that makes a difference.
    I doubt it will, but it's worth a try. I'll do some more digging and post any solution, if I find one.
     
  3. macs4nw macrumors 601

    macs4nw

    #3
    When you say "OS X gets very upset" do you mean you get messages saying 'drive not properly ejected"? If so, that's apparently a common problem, and there's tons of info about that available. Here are a few links to check out. There are many more threads on the subject available, suggesting different work-arounds.

    https://discussions.apple.com/thread/6174599?tstart=0 ***read further down to poster 'prokopton'
    http://apple.stackexchange.com/ques...attempts-to-eject-external-drives-after-sleep
    https://discussions.apple.com/thread/6607988 ***read pictureboy's answer to first post
    http://osxdaily.com/2012/05/14/prevent-slow-down-mac-os-x-external-hard-drive-access/

    Let us know if you were able to solve the problem.
     
  4. MrFusion thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
    Location:
    West-Europe
    #4
    Yes, that is the message.

    Thanks for the info.
    I enabled power nap. Will see how that goes.
     

Share This Page