Power issue....

Discussion in 'MacBook Air' started by jmhall28, Aug 26, 2017.

  1. jmhall28 macrumors newbie

    Joined:
    Aug 26, 2017
    #1
    I have a 13" 2012 MacBook Air. When I plug in the power cable the LED does not light and the battery does not charge. However, if I remove the battery connection from the logic board, the LED lights. When I re attach the battery to the logic board it charges. If I remove the power cable and reattach it, while its charging the LED will not light and the battery will not charge. I've tried changing power cables (with a brand new charge and the problem remains. I've tried to reset the PRAM AND SMC several times and the issue remains. I'm at point where I either try replacing the battery or the logic board.

    My thoughts, since the power cord does charge the batteries, the it cannot be a connection issue. Also the USB and headphones work without issue. I have a feeling the issue is simple but I'm not sure. Replacing the battery is cheap but the logic board, is cumbersome as well as $$$.

    Any ideas? I appreciate the feedback.
     
  2. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    If there is an Apple Store near you, take it there so they can test the charger and Air.
     
  3. jmhall28 thread starter macrumors newbie

    Joined:
    Aug 26, 2017
    #3
    THANK YOU!!!! They lead me to the answer. Turns out it was the logic board. I purchased one online for $180.00 and boom! Everything works!

    Thank you so much for the your advice!
     
  4. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #4
    Hey, that's great news :D Sounds like you got a very good deal on the board. I would never see anything close to that price in Toronto.
     

Share This Page

3 August 26, 2017