Power Mac G4 disillusionment! (Help me troubleshoot)

Discussion in 'Mac Basics and Help' started by REVOLUTION GUNS, Aug 24, 2008.

  1. REVOLUTION GUNS macrumors newbie

    Joined:
    Aug 24, 2008
    #1
    Long time reader, first time poster. What follows is kind of a long story, but any insight would be greatly appreciated.

    NONESSENTIAL BACKSTORY

    After working in MIS/IT for three years, I decided that I was going to leave Windows at work and let Apple into the house. This was partially because I wanted a change, and partially because I was exposed to Macs (via Max/MSP and Digital Performer and the like) in UVA's McIntire Department of Music. I got rid of my Windows PCs and welcomed a brand new MacBook Pro to the family.

    NEW ADDITION TO THE FAMILY

    Wanting to expand the family a bit, I got my hands on an ailing 867MHz Quicksilver G4 (specifications at Low End Mac) and used TechTool Pro to verify all of its hardware. Turned out that it needed a replacement hard drive. Installed that and everything worked swimmingly in Tiger.

    Received a second stick of 512MB PC133 memory and threw that in, and it ran even better. Dug up an NVIDIA GeForce 4 MX from a newer MDD G4 and upgraded the video as well. The interior's finishing touches were a USB 2.0 controller, an 802.11G card, and a DVD writer. Picked up a 17" Studio Display and a Pro keyboard and mouse on eBay, and I had a bona fide retro rig to make up for my Macless computing adolescence. My girlfriend really wanted a Mac, and so this would be the compromise until she could afford a MacBook.

    BIG(GER) CAT

    Now, about this time, 10.5.3 dropped. I was finally really happy with Leopard on my MacBook Pro, so one weekend I decided to see if the old G4 could keep up with the new big cat. I got Leopard installed and was fairly impressed. It wasn't the swiftest, but it worked. Grabbed the 10.5.3 update and things seemed stable.

    One problem: she would no longer wake from sleep! Given, Tiger took a while to wake, so I thought it just needed some time. No dice. I'd wake up the rig via mouse shake or either of the two power buttons, and after a couple of seconds of being responsive, I'd get a Perpetual Pinwheel. I waited 15 minutes a couple of times, and once or twice I even got a kernel panic.

    Frustrated, I yanked all of my aftermarket hardware (the USB controller, wireless card, and memory). Same problem. Swapped the video card back, and still, same problem. Thought that it may be the USB devices connected to the Studio Display's USB ports or the Studio Display itself, but same issue with a VGA CRT connected. Disconnected the keyboard and just used the mouse... same. Tried a different mouse, but no go.

    Waited for 10.5.4, and was once again disappointed. My last ditch efforts were resetting the PMU with the onboard switch, resetting the PRAM, and replacing the CMOS battery. None of these worked. I could either stick with 10.5.0 or run Tiger, and I really disliked having to choose. Tiger's great, but I really would like to run Leopard so my girlfriend can get to know it before she gets a MacBook.

    BIG BROTHER G4 AND THE UNSOLVED MYSTERY

    I got a new job in June, and while cleaning up some storage, I dug up some old Macs retired from my business's Creative department. Among the orphans was a 1GHz MDD G4 (specs at Low End Mac). I took the slightly beefier machine home with high hopes, and bizarrely, the story is the same. It won't wake from sleep with Leopard, either. I pulled all of the hardware I'd installed and it still pinwheeled on me.

    The only piece of hardware that is the same between the two G4s that I haven't already ruled out is the hard drive. It passes its SMART self-test and has passed all of the TechTool Pro tests. I can replace it for fairly cheap, and I'll probably try this last. (I can't do this at 11:00PM on a Sunday night, though, hence why I'm here!)

    HARD QUESTIONS

    1) Does anyone here have a G4 (preferably a Quicksilver or MDD with similar specs) that's happily running 10.5.4 without any problems waking?
    2) Do any grizzled technicians or Geniuses have any ideas or leads? Ask anything and everything--although I've probably done it, there's a chance I haven't, and I'm desperate. (Keeping it on all of the time is not an option. Consumes too much power and is much too noisy.)
    3) As an aside, does anyone know why System Profiler would report only one processor in the MDD? From what I understand, all of the machines in this series have two processors. I've tried the Open Firmware commands to set processor access to defaults in case the second processor had been disabled for some reason, but to no avail.


    I look forward to your replies!
     
  2. WOZhipper macrumors newbie

    WOZhipper

    Joined:
    Nov 2, 2007
    Location:
    Mexico
    #2
    I have a g4 MDD 1 ghz with 768 mb ram and 2 hdd internals 23 cinemadisplay works perfect with 10.5.4

    Naybe the install is corrupted, start from another install *HD and test...
     
  3. REVOLUTION GUNS thread starter macrumors newbie

    Joined:
    Aug 24, 2008
    #3
    I've reinstalled several times on both machines now. I'm thinking more and more that it's the hard drive, as it's the one common component between the two towers, although I can't think of a reasonable explanation why.

    Good to know someone has a working MDD out there, though. I've not lost hope yet. I'll pick up a HDD and see what happens.

    By the way, WOZhipper, can you take a look in your System Profiler and tell me what it says for "Number Of Processors" on the first page (Hardware)? I'd like to make sure that one of my processors isn't toast or something.

    Thanks!
     
  4. djtrippin macrumors newbie

    Joined:
    Aug 5, 2008
    Location:
    Grand Rapids, MI
    #4
    Your HDD may be in the early stages of failure. I have had hard drives in the past that the first sign of failure they would show was inability to properly restart when the system returns from sleep. That would also explain the spinning ball of death lockup.
     
  5. REVOLUTION GUNS thread starter macrumors newbie

    Joined:
    Aug 24, 2008
    #5
    Ordered a replacement HDD last night. I'm really hoping that it solves the problem.

    I've seen dying hard drives do a lot of strange things over the years, and if this is indeed a drive issue, it wouldn't shock me. I wonder, though, why the issue would only be manifesting itself in Leopard. I'd imagine that there's some difference in how Tiger and Leopard wake, but anything I'd posit would be wild speculation.

    In any case, thanks for the comment. I'll update when I get the new storage.
     
  6. brisbaneguy29 macrumors 6502

    brisbaneguy29

    Joined:
    Nov 27, 2007
    Location:
    Brisbane
    #6
    Suspect HDD

    From reading your post, if I had problems like this, the first place to look would be the CMOS battery, the USB controller, or the HDD. Seeing as you have replaced the battery, removed the USB, that only leaves the drive. I had an iMac that would crash, and not wake, problems installing, and in the end, a brand new HDD fixed the problem.
    I would be very surprised if the new HDD doesn't fix the problem.

    Let us know!
     
  7. Craig1 macrumors newbie

    Joined:
    Aug 25, 2008
    Location:
    Auckland NZ
    #7
    MacBook Pro > iMac G4 (Flat Panel)

    Hi apple MacBook Pro working wireless and a Flat screen G4 plugged in to router. I can not log in to the G4 and see my other hard drive but only as a guest ? help
     
  8. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #8
    How did you upgrade to leopard? Did you do an erase and install, or one of the other install types? (forgive me if you already mentioned this in your original book, uh, I mean original post ;) )
     
  9. REVOLUTION GUNS thread starter macrumors newbie

    Joined:
    Aug 24, 2008
    #9
    No worries. I've performed erase and installs on both machines.

    (As an aside, new hard drive arrives tomorrow. I'll be throwing it in the MDD as soon as I get home from work.)
     
  10. MacHappytjg macrumors 65816

    Joined:
    Mar 24, 2008
    Location:
    Winnipeg
    #10
    so what ya doin with the qucik silver?
     
  11. REVOLUTION GUNS thread starter macrumors newbie

    Joined:
    Aug 24, 2008
    #11
    I had a feeling that it'd work, but yes, the hard drive did solve the problem. Thanks to everyone that posted. I feel like such a rookie, but to give myself some credit, as soon as I typed "The only piece of hardware that is the same between the two G4s that I haven't already ruled out is the hard drive..." in my original post, I semi-realized what was going on... I think. :apple:

    Delightfully, the MDD wakes up pretty much immediately, which is how it should be. It also boots in 1/3 the time. My girlfriend will be much happier now!

    Still waiting to see if anyone with a 1GHz MDD can verify their System Profiler and see if it lists one or two processors.

    (Oh, and last, but not least, I've had a persistent and strange graphical issue with both of these G4s. When I have a Stack that has enough items to show up as a grid instead of a fan, I get some noticeable graphical corruption around the edges of the background of the grid. It's subtle, but it bothers me more because I really have tried two different graphics cards.)
     
  12. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #12
    If the problem of not waking up was caused by the hard drive, the problem may not actually that the drive was faulty, the problem may be that the jumper settings on the drive were set incorrectly. What are jumpers and how are they supposed to be set you ask? That's a rabbit hole you shouldn't jump down unless you're interested in doing something with that hard drive.
     
  13. REVOLUTION GUNS thread starter macrumors newbie

    Joined:
    Aug 24, 2008
    #13
    The problematic drive's jumpers were set to master. The new drive is set to master as well. Didn't try the original drive with cable select.
     

Share This Page