Power Mac G4 doesn't boot from DVD

Discussion in 'PowerPC Macs' started by anonymouse91, Jul 14, 2008.

  1. anonymouse91 macrumors newbie

    Joined:
    Jul 14, 2008
    #1
    Hi,

    A while ago, I got hold of an old Power Mac G4 (450MHz, 128MB RAM, OS X10.3) which I haven't dug out until now. As it contains the old owner's data, I thought the best thing to do would be to do a clean install of Tiger.
    I bought a Tiger DVD set and upgraded the RAM to 1GB but the DVD won't boot. The DVD is mounted in OS X and I can access the launch screen which has a button to restart and upon restarting, OS X just boots again.

    I have tried pushing C and Alt (I have a Microsoft Bluetooth keyboard as the Apple one has been misplaced - Could this be the problem?) but nothing appears on the the display for a while, then OS X boots. I have also tried setting the Startup Disk to the Install DVD which doesn't work either.

    I was also thinking it could be the DVD-ROM drive as the button to eject is in the center whereas the drive's eject button is on the right (so I am guessing it isn't an original part)

    Any ideas?
     
  2. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #2
    Borrow a wired keyboard. Boot time key presses on wireless are problematic -- the machine has to boot up far enough to load the Bluetooth software and recognize the keyboard.

    Ted Landau writes in MacObserver

    Also: Is the OSX Tiger disk you have a retail disk , or one that shipped with a Mac? If it came with a Mac, the OSX disks are customized per Mac model, so to work it has to be the same model as your Mac, or a close relation.
     
  3. Jiff Lemon macrumors member

    Joined:
    Apr 8, 2008
    #3
    I had problems on one of my machines where the DVD drive had been replaced. the drive was visible in OSX but wierdly wouldn't boot. Set the jumper to CS (cable select) and voila! it would boot.
     
  4. anonymouse91 thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    #4
    Thanks for your replies :)

    I'll try looking for the Apple keyboard, a wired USB one or i'll try pushing the keys when the light flashes on the Bluetooth dongle.

    If it doesn't work, I'll try setting the DVD drive to CS or I'll replace it with another.

    The DVD is retail.
     
  5. anonymouse91 thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    #5
    I just tried holding the keys when the light flashes but OS X just boots up in Safe boot, no matter which key I hold. Nothing appears on the display for a while until the OS X load screen shows (just before login).

    I can't try a different keyboard at the moment but will later. Though, I'm beginning to think that it could be something to do with the display as if it was booting into safe mode, it must be recognising the key presses so maybe the boot menu is showing up but I can't see it because of the display.

    I'm going to try a different monitor and try changing the drive jumpers if I can figure out how to remove the drive first :eek:

    EDIT: I've just tried with a different monitor and managed to get it onto the boot menu by holding Alt (Option). The only option listed is Mac HD and there are 2 buttons (I'm guessing restart and continue). I didn't manage to get to the DVD Drive to check the jumpers but I am going to try an external drive later on.
     
  6. anonymouse91 thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    #6
    I've just tried multiple times to get it to recognise the Install DVD with no luck. All it shows is the Mac HD. Are there any other ways I can just format the HD and install Tiger?

    Sorry to be a pain with these problems but I really need to get this working. Also, if someone could point me to some instructions on how to remove the DVD drive in a Power Mac G4, that would be great.
     
  7. anonymouse91 thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    #7
    New problem. Anyone know how to fix error -20, restoring in Disk Utility?

    I've given up on using the DVD drive as it seems like it cant even read other bootable disks.
     

Share This Page