Power Mac G4 MMD's won't boot (x3)

Discussion in 'PowerPC Macs' started by 92WardSenatorFE, Nov 17, 2009.

  1. 92WardSenatorFE macrumors regular


    Dec 29, 2008
    Hey guys,

    At my school my multimedia teacher is trying to get three different Power Macintosh G4 Mirror Door Drives to work. All of them have at least one different thing wrong with them, let me explain.

    All of them are 1GHz G4s (if I am correct), 512 MB RAM, and 80 GB HDD's (if I am correct, again). All of them are running 10.2 (factory installs) . (We're not the kind of school that keeps the computers up to date). I believe we have all the restore CD's for these computers, however we do not want to reinstall the OS due to we are looking for specific files on them (video footage).

    #1: This computer used to work but was highly unreliable. It would take literally 5 minutes to boot, the superdrive has a disk stuck in the drive and will not open, and would lock up constantly and gave kernel panics. About a week ago we decided to open it up to take the RAM out of it, however found out it wasn't compatible with Quicksilvers and put it back in. We tried booting it up today, and it made a loud BEEP noise and turned back off. The RAM is secured.

    #2: This computer will not turn on. The monitor receives power (studio display LCD) but I believe the power button is broken because it goes farther in than what it is supposed to. We currently have been using this machine to try and get parts for the others.

    #3: This G4 will turn on, but will not output picture to the display. The light stays lit and it sounds like its booting up, but we've tried two different monitors (Studio LCD's) and none of them would show picture. The power light stays orange when connected to them.

    For the most part, we need enough advice to get at least *one* machine operable, and then we will need to know how to transplant the hard drives out of these machines to look for the files we need. We tried getting the hard drive out of one but we couldn't figure out how to open the caddy that they are in without prying it open.

    Many thanks and hope you can help! We've tried researching this, but due to we're looking at 3 different problems on 3 different machines we were fruitless.


    *Also note some of these machines appear to have two internal HDDs, maybe 2x40GB?
  2. ClassicII macrumors 6502


    Sep 21, 2009
    Chicago, IL
    Seems you guys have a lot of things going on here! hehe. Well lets get one of those babies running.

    First off your machines run PC2700 or 333mhz ram and came stock with an 80GB hard drive. The other drive has to be an extra drive that most likely is for files or data.

    On the first machine, you are right the quicksilvers use SDRAM PC133mhz its possible that some how they were damaged. The beep you hear means that the computer can not read the RAM. It also sounds like that machine needs a fresh os install from all the problems you have said it has been having. You can do a archive and install and still keep your files with no problem.

    On the Second machine it sounds like this machine is running right? I mean the power button works but just goes in to far right?

    On the 3rd it could be as simple as the video card is toast. You will know if when you turn on the machine it will chime, the power light will stay on and you will hear the hard drive start to do things. If all that happens its most likely you have a bad video card.

    Also if you are trying to get the caddy out each one has a latch. But first you must take the top screw out and then you can pull out on the latch a bit then push up to slide the caddy up and out.

    When you get one of them working then you can connect any of the other hard drives as a slave and recover all the data.
  3. 92WardSenatorFE thread starter macrumors regular


    Dec 29, 2008
    Thanks ClassicII.

    Yeah, we're kinda in the middle of trying to get all this equipment to work. Needless to say, the teacher was editing a video of his sons wedding when the computer died and he couldn't get it working and all the other ones were acting up so he disconnected all of them, and doesn't remember which ones had the files on it. (this was about a year or more ago)

    #1.. we could try taking the RAM out of another MMD and putting it in. I'll see tomorrow. I know the machine did work before we pulled the ram, but the ram is located at a hard to reach location to install/ uninstall and secure it.. there might be a easier way to do it, but I'm not sure how to move anything around in it.

    #2.. I have no idea if it works. All I know is the power button on the front is more than likely broken.. and we don't have any older keyboards with the power button to try anything else with it.

    #3.. I don't think the machine chimed but don't quote me. A red light inside is also on by the RAM. I haven't tried but I read somewhere while researching it might have something to do with the PRAM and another symptom was the CD drive won't open.. but I don't have the machine on me to test anything until tomorrow.

    And thanks for the info about the caddy.. We wasn't sure at all, I'm not that familiar with computer internals but I know a lot of the basic stuff.

    Thanks so much.

Share This Page