Power Mac G5 (late 2004) Permissions and Disk Utility Problem... Please help!

Discussion in 'Mac Basics and Help' started by Firewolf34, Jan 6, 2009.

  1. Firewolf34 macrumors newbie

    Joined:
    Nov 29, 2008
    #1
    Hey everyone. I have sort of a problem. I love my Mac and it has always worked for me. It could do everything I wanted it too, I had like 700$ of graphics/video cards and RAM installed. It was pimped. But now something bad happened while I was fixing up an account for my friend for while he stayed over. I really need some help with this. I cant use Apple support because it costs money, and I'm way outside of my warranty (Bought it from my friend and its OLD and I don't have the AppleCare plan.). One day, I decided to create a guest account for my friend, who doesnt know anything about macs, or the Internet for that matter. I needed to restrict him from destroying my computer (no touchy my Terminal.). So one day, I went into Parental Controls in my System Preferences pane. I opened up the guest account and changed the permissions under the "System" subcategory. I practically locked everything except for Firefox and some other programs (this was temporary for my guest account of course). Then, when I logged onto a Standard account, it was all messed up and most of the applications did not have access to the System files for scripts and things (thats my theory at least). Applications couldn't use Flash Player, because they didn't have access to the file. The printer didn't print (it thought it did at least.) StuffIt Expander couldnt run because it couldn't use the StuffIt Engine (now I cant install Flash Player). If things could be any worse, my Google wont work. Firefox broke and it cant find my accounts (Im a developer so I have accounts on Firefox). I deleted the Standard account that wasn't working. I made another and promoted it to Admin. Worked like a charm. Turned off Admin (I needed too, I don't want my bro to prank me by dropping his AppleScript pranks into my desktop and making me think its Firefox again) and it broke again. I deleted the Guest account and tried the entire process over. No dice. My account worked fine until today, where now my I'm having the same issues as the other Standard ones. So, pissed off and worried as I was I decided to resolve it and use Disk Utility. I checked Disk Permissions of my internal hard drive. No luck. It said in red letters that it failed, and would say the same if I repaired them. At last I decided to delete my free space. Its the last thing I was aware I could do. Now as you know(hopefully), Disk Utility makes a massive temporary file on your computer for some reason. It then deletes it. I had 56 GB left on my hard drive, but when it copied my hard drive to the file, My hard disk ran out of space. I needed to close the Disk Utility, but it wouldn't close so I forced quit it. Now my hard drives completely friggin full (0 bytes left)!!!! This is a very large problem and I was hoping that someone could help me with both. And by the way, thanks for reading my very long wall of text....


    - :apple: Firewolf34
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    It isn't just a large problem, it's a very large paragraph. :cool:

    I suggest booting from your computer's install disks (you do still have them, yes?). You can find Disk Utility under the Utilities menu, and you should have more luck with the erase free space task there.

    After that's taken care of, we can take a look at your permissions issue.

    Oh yeah, and I used to have one of those. Very nice machines! I ended up selling it for a rev A MacBook Pro when I moved out because it would be so inconvenient to carry the CPU and display around with all the moving and traveling and so forth, but it served me well for a few years.
     
  3. Firewolf34 thread starter macrumors newbie

    Joined:
    Nov 29, 2008
    #3
    Thanks for the help, and sorry for the really late reply. I reinstalled Mac OS Leopard, and ran a program called Maintenence 3.8 that I got off of the Apple homepage. It found over 1000 permissions problems! Luckily it fixed them and my computer works fine now. :)

    Firewolf34 
     

Share This Page