Power Mac G5 startup issues

Discussion in 'PowerPC Macs' started by TanDodge, May 30, 2013.

  1. TanDodge macrumors newbie

    May 30, 2013
    Hey all,
    A Power Mac G5 has recently come into my possession from a deceased family member. After his death a cousin of mine apparently formatted the machine, and left it with the OSX install disks. Problem: I get to the flashing question mark face folder, even with the install disk in the drive. The optical drive definitely spins. I have tried the "hold c to boot from disc", I have tried resetting the PRAM, I have tried the 'hold option' to get to the boot selector, but when I get to the boot selector screen, there are no icons to select a boot option, just an arrow and a circular arrow. Thinking it was a hard drive issue, I disconnected both hard drives that are in the machine, all to receive the same results. Help..?

  2. MysticCow macrumors 6502a

    May 27, 2013
    The CD drive is probably dead. This happens a lot of times and is nobody's fault.

    You will need to find a working Firewire CD/DVD drive (the OS is on a DVD). Also make sure you're trying to boot Mac OS 10.5 off of the disk, UNLESS it is the original system restore from the G5.

    Since that is rare, it's likely you have a generic OS install disk and it needs to be 10.5 only. The G5's used a 10.4 build that is not on that install disk.
  3. TanDodge thread starter macrumors newbie

    May 30, 2013
    Thanks, I managed to get to Open Firmware, where I attempted to boot from CD using commands and it gave me a could not open error, which may support your conclusion. Can I just replace the optical drive rather than hunt down a firewire drive? Also, does any of this indicate hard drive failure?
  4. MisterKeeks macrumors 68000


    Nov 15, 2012
    Yes, you can replace the optical drive. I believe there is a guide on iFixit but it's nothing too fancy. There is a lever that you use to unlock the drive, you remove the cables, and unscrew the 4 black doohickeys on the bottom, put them on the new drive, and reverse the process.

    The fact that it isn't seeing the hard drive is weird. Try reconnect the HDs and trying to see those again when you hold option.

    Make sure you wait long enough for it to find all bootable devices. Wait until you get to the screen with the regular cursor.
  5. TanDodge thread starter macrumors newbie

    May 30, 2013
    Thanks, I'll try a new drive. I am somewhat sure my grandfather put the present hard drives in himself, so maybe they are of unreliable quality or just bad. I definitely wait until the watch turns into a cursor arrow; nothing shows up.
  6. TanDodge thread starter macrumors newbie

    May 30, 2013
    An update...I replaced the CD drive, I had to get a SATA adapter and all, but it was to no avail. Everything was the same. Still no icons in boot selector, and Open Firmware gave me a "Can't open" error. Also, while in Open Firmware, I decided to try the generic "boot" command, and got the message "Warning: sector size mismatch!" along with a can't open from hd message. Any ideas on what this means..?

  7. MisterKeeks macrumors 68000


    Nov 15, 2012
    Sounds like a bad hard drive to me. I could be wrong though.
  8. tydiamond11 macrumors newbie

    Mar 28, 2013
    O had this same problem with a iMac g5 17 inch and I used a USB DVD drive and it did not work the hard drive is there but nothing is on it. I tryed using open firmware with a usb thumb drive and it did not work it got it too the apple logo with the thing going round and round but it froze and crashed this has been an issue for a year or so any help would much appreciated!
  9. skinniezinho macrumors 65816

    Jan 1, 2009
    me too
  10. kozzzie76 macrumors newbie

    Jun 18, 2013
    Brisbane Australia
    G5 Start up Problems solved

    I just purchased a G5 1.8ghz 7.2 model with no hard drive.
    I tried installing 10.5.6 from retail disk and after holding C i got the face and question mark blinking then it would spit out the disk.
    I tried resetting ram and all the other trouble shooting mentioned with no luck.
    To cut it short all I done was format the drive in my mac pro swapped to PPC then changed my internal dvd drive with an old one out of my PC and BAM its just finished installing and running smooth.

    Hope this helps someone


Share This Page