Power up issue, power button?

Discussion in 'Mac Pro' started by gxgn, Nov 2, 2013.

  1. gxgn macrumors newbie

    Joined:
    Feb 11, 2011
    #1
    Hello, I'm hoping someone here know an answer to this issue, I have a 2010 Mac pro 10.6.8, 2.8 quad (out of warranty). For more than an year i have a hard time starting the machine. I have to press the power button many times.

    It usually starts only after I hear a click, but not right away, maybe the third time I press after hearing the click. In a bad day I could press it 5-10 times until I hear a click and then a few more times until it starts.

    I noticed that it seems to be dependent of the angle, and pressure I apply, so not pressing too hard nor too light, almost moving my finger on the button when I press it.

    I have tried the usual culprits, reseting SMC, looking at diagnostic lights etc. Nothing seem to fix it, nor does it appear something is broken. It's moody :)

    I know the usual advice is change power supply. I don't have the money for this right now, DO YOU THINK IT COULD BE THE POWER BUTTON? do these ever go bad?

    thank you all,
    george
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    I could be a hard drive dying slowly, have you checked that angle?
     
  3. andrejkw macrumors newbie

    Joined:
    Jun 28, 2010
    #3
    Sounds like it could be a bad power supply. Although, it is entirely possible that your power button has gone bad.

    Does it have any issues waking up? Have you tried powering on the Mac by scheduling a startup time?
     
  4. gxgn thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #4
    I didn't hink of that, i will try it. So if it starts with no issues when scheduled does it mean the power source is good?

    Satcomer, I don't think it's a hard drive, But i will scan them just to be sure.
     
  5. macuser453787 macrumors 6502

    Joined:
    May 19, 2012
    Location:
    Galatians 3:13-14
    #5
    Sounds like a power button issue to me too, based on what you've described. Any success with your tests?
     
  6. gxgn thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #6
    Unfortunately, I'm starting to believe it's the power supply... I programed the machine to start at a certain hour and didn't work. I tried to put it to sleep at a certain hour and didn't work either (you could hear a faint sound when the setup time came but didn't go to sleep).

    Interesting fact, when I programmed the machine to wake up at an hour, it didn't work but the power button didn't work either, no mater how many times or how I pressed it. However, when I removed the power cord and plug it back in the computer started without pressing the button. Almost like it had the command to start stored in. Weird.

    Any thoughts how to test the power supply?

    thank you all
     

Share This Page