Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

TJ82

macrumors 65816
Original poster
Mar 8, 2012
1,230
813
Worked great yesterday, had them for over a year. Just went to use them now and.. nothing. No sound. Connection seems fine to iPhone and MBP. Tried the usual tricks, forgetting device and resetting etc.

They seem dead. Left one completely, but right one makes a weird sound, like some sort of radio wave meter you'd see in an 80s movie. Don't know how to describe it better.

More I shake head the more aggressive that noise will become.

Any ideas here? Really hope they're not junked. These are out of warranty.
 
  • Wow
Reactions: Retrostarscream

razmonster

macrumors regular
Dec 22, 2017
196
76
11372↔️90254
ive had mine replaced twice and i eventually bought a new pair. constantly having issues with the left one showing as a dead battery. After Apple replaced them twice and it was still happening I just want to Walmart and bought a new pair and then returned the broken ones. Pretty much the same thing is happening still
 
  • Sad
Reactions: Retrostarscream

Runs For Fun

macrumors 65816
Nov 6, 2017
1,138
2,601
ive had mine replaced twice and i eventually bought a new pair. constantly having issues with the left one showing as a dead battery. After Apple replaced them twice and it was still happening I just want to Walmart and bought a new pair and then returned the broken ones. Pretty much the same thing is happening still
I bet it’s not getting seated properly in the case and isn’t charging. If you’ve ever adjusted the ear loops it can affect how they sit in the case when it’s closed.
 
  • Like
Reactions: Retrostarscream

BulkSlash

macrumors 6502
Aug 20, 2013
267
697
I had exactly this happen to me the other day. I had to hard reset them about 5 or 6 times before they started working correctly again. I don’t know if there was a specific order, I tried deleting the pairing first in some cases and I tried first pairing them with my iPhone or my iPad. Eventually it started working.
 

Retrostarscream

macrumors member
Sep 13, 2010
99
17
Miami FL
Worked great yesterday, had them for over a year. Just went to use them now and.. nothing. No sound. Connection seems fine to iPhone and MBP. Tried the usual tricks, forgetting device and resetting etc.

They seem dead. Left one completely, but right one makes a weird sound, like some sort of radio wave meter you'd see in an 80s movie. Don't know how to describe it better.

More I shake head the more aggressive that noise will become.

Any ideas here? Really hope they're not junked. These are out of warranty.
I know the exactly sound you're speaking of. Mine do that same frequency noise occasionally and is really annoying ? when it happens.

I place them back in their case and leave them alone for a while and come back to them to find the sound is no longer there nor an issue. ?
 
  • Like
Reactions: TJ82

7thson

macrumors 65816
May 13, 2012
1,340
1,432
Six Rivers, CA
Well if you made it this long w/o any other fuss count yourself fortunate. PBP are the best fitting wireless earbuds I’ve used and the most problematic by a long mile. Thoughts and prayers that they return to service for you. They are too expensive to be as glitchy as they are. I have a $20 pair of off brand wireless earbuds that are more reliable than the PBP.
 

TJ82

macrumors 65816
Original poster
Mar 8, 2012
1,230
813
Well if you made it this long w/o any other fuss count yourself fortunate. PBP are the best fitting wireless earbuds I’ve used and the most problematic by a long mile. Thoughts and prayers that they return to service for you. They are too expensive to be as glitchy as they are. I have a $20 pair of off brand wireless earbuds that are more reliable than the PBP.
These are my replacement PBS!
 

razmonster

macrumors regular
Dec 22, 2017
196
76
11372↔️90254
so I did a little digging and apparently there are a ton of issues with PBP With battery drain and one earbud not working sometimes it's all over reddit and even apples own forums. What's strange is that this is not new this has been happening since they released these so I don't know why they haven't sent out an update
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.