powerbook battery

Discussion in 'Macintosh Computers' started by rick98761, Nov 30, 2005.

  1. rick98761 macrumors 6502

    Feb 18, 2005
    Kansas City, MO
    Yesterday morning I was using my laptop, I ran the battery until it went empty. Right as it was about to fall asleep I plugged it into AC power. At this point I left to go do some stuff. I came back to find that the AC power wasnt actually plugged into the wall, no big deal right? I just plugged it in. Funny thing is the computer wouldnt wake back up for about 5 mintues. I don't know if that is a problem, I assumed it would wake right back up with AC power but i'd never ran the battery that low before. Anyway onto the problem, The battery charged from 0-100% in about 15 mintues, but I only get like 30 minutes of battery life. I've tried rebooting, and even doing the key command on apples website to reset the power regulator thing. Didn't help at all. I downloaded Capacity Meter and it said my battery can only hold 10% of its capacity. This battery went from about 3.5 hours to 30 minutes in a matter of a few hours. Its a brand new 15" Powerbook that is not even a month old. I know I can probably just get it replaced with no hassles at the apple store, but I just want to make sure im not missing something obvious I can do to fix it.

    Short Version: All the sudden my battery can only hold a 30min charge when it could hold 3.5 hours a few hours ago.
  2. rick98761 thread starter macrumors 6502

    Feb 18, 2005
    Kansas City, MO
    btw, when it reaches 0 minutes left it does fall asleep, its not like a read someplaces that it will sit at 0 minutes for an hour and it just needed to be recalibrated.
  3. Kobushi macrumors 6502a


    Jun 7, 2005
    Right behind you.
    Have you checked to see if your battery is on of the ones being recalled by Apple? The defective batteries are supposed to overheat, but yours may still be in there. Check out Apple's site.
  4. rick98761 thread starter macrumors 6502

    Feb 18, 2005
    Kansas City, MO
    no sadly its not. The recall was about 4 months ago or so. My girlfriend has an iBook and that was involved in that. It was a while before this rev of powerbooks came out.
  5. Tommyg117 macrumors 6502a


    Sep 27, 2005
    Philadelphia, PA
    something similar happened to my powerbook. I just got the battery replacement
  6. adk macrumors 68000


    Nov 11, 2005
    Stuck in the middle with you
    apple recommends that you run the battery down until it does go to sleep. I'm not sure what it does, but apple recommends it. try that maybe?
  7. smartgirlglasse macrumors newbie

    Oct 21, 2005
    My Powerbook just did the same thing!

    I left it on, came back after 30 minutes and the thing had shut itself down, but it's reading that my battery is:

    Battery Installed: Yes
    First low level warning: No
    Full Charge Capacity (mAh): 518
    Remaining Capacity (mAh): 329
    Amperage (mA): 2687
    Voltage (mV): 12037
    Cycle Count: 24

    It was 4000 about three weeks ago.

    Keep me posted on how yours is doing... it looks like I'm going to have to take mine in once my final exams are over. Sheesh!
  8. Morn macrumors 6502

    Oct 26, 2005
    That will be covered under warranty, you'll be able to get the battery replaced.
  9. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I'm assuming you guys tried to calibrate it again, right? Sorry if it's a stupid question, but it's the first thing I'd try. :)
  10. Seasought macrumors 65816


    Nov 3, 2005
    I'm actually having a similar problem. My Powerbook just turned off while I was in bed and surfing online. No message about the battery running low or anything. Battery read 80% before it did this. I plugged it in to the adapter and the battery reads 6%. CoconutBattery says I only have 22% of my original battery capacity. So, things were fine about twelve hours ago and now this. I'm going to try and recalibrate the battery again. I was hoping I'd at least have this thing for a month before any problems occurred.

    I guess I'll post if I resolve this in any fashion. :(

Share This Page