Powerbook doesn't see my external drive

Discussion in 'PowerPC Macs' started by jck905, Aug 13, 2008.

  1. jck905 macrumors newbie

    Aug 13, 2008
    I just got a new G-drive mini for my PowerPC G4 Powerbook and I used the firewire to connect and my computer doesn't see the hard drive.:mad:
    I tried the usb cord as well and I restarted etc etc.
    I checked the disk utility and nothing is their either!
  2. TEG macrumors 604


    Jan 21, 2002
    Langley, Washington
    If you use it on USB you need external Power. It simply sounds like your system isn't powering it via FW, which may mean a busted FW port, or simply a blown fuse.

  3. jck905 thread starter macrumors newbie

    Aug 13, 2008
    but i tried my firewire as well. do i still need an external powersource?
  4. Firefly2002 macrumors 65816

    Jan 9, 2008
    Do other similar drives work?

    You might try repairing permissions and deleting extensions.mkext and extensions.kextcache, then restarting your Mac.
  5. jck905 thread starter macrumors newbie

    Aug 13, 2008
    just tried out a LaCie 'rugged' drive and no cigar.
    will deleting those files screw up my computer? i'm kinda scared to randomly delete things :confused:

Share This Page