Powerbook G3 "Lombard" CD malfunction - Please Read

Discussion in 'PowerPC Macs' started by revenuee, Aug 10, 2008.

  1. revenuee macrumors 68020

    revenuee

    Joined:
    Sep 13, 2003
    Location:
    A place where i am supreme emporer
    #1
    So i've recently dug up my old G3 powerbook, and trying to breath some life into it.

    It currently runs OS 9.2 - And I want to Install Linux

    Anyway - the CD-rom drive seems to be malfunctioning. Every time i put a CD in I get an Initialize Disk menu

    The old:
    This disk is unreadable by this Computer. Do you want to initialize the disk?

    Name: untitled
    Format: ProDos 0K


    I know that the CD's are formatted correctly because I connected and Old external CD burner and it reads the Disk no problem.

    I even tried OLD audio CD's released pre this powerbooks existence and they won't open/play either.

    The problem this is causing is that I can't boot from any CD - be it the install disk for OS 9, the Linux install disk I made (I know it works because i've used it to install Linux it on my G4), I've tried my Jaguar CD, I've tried my Tiger CD

    nothing works

    Obviously they mount when I use the external drive, But it won't let me boot off of that drive.

    I was considering installing the system file unto a USB drive, but I have no reason to believe that it will work.

    The other possibilities are taking out the Drive, and using a different computer to install the OS and the putting it back into the G3.

    Thoughts?

    any thoughts on what might be a malfunction in the CD drive?

    thanks
     
  2. revenuee thread starter macrumors 68020

    revenuee

    Joined:
    Sep 13, 2003
    Location:
    A place where i am supreme emporer
    #2
    anyone?

    my USB drive says it's unsupported so I can't initialize it under OS 9

    I'm going to run out and get a 2.5 inch IDE adapter so I can swap it into one of my desktops when the stores open -- and try that

    but anyone know how I could test for what's wrong with my CD drive?
     
  3. Firefly2002 macrumors 65816

    Joined:
    Jan 9, 2008
    #3
    It just sounds like your optical drive is bad. That happens, perhaps especially on laptops... in my experience, optical drives never last very long. Just try ebaying one to replace it with. Lombards are fun computers.
     
  4. revenuee thread starter macrumors 68020

    revenuee

    Joined:
    Sep 13, 2003
    Location:
    A place where i am supreme emporer
    #4
    any suggusted alternatives? (I'll take a look on ebay -- I feel it might be tough though)

    I'm having trouble booting off of a external CD drive -- it does mount once it loads on system drive

    and I can't boot off of a USB drive I installed OS 9.1 on either

    any ideas/thoughts, suggestions

    I'm even considering doing a netboot -- but i have 0 experience with such a set up
     

Share This Page