Powerbook G4 airport problem

Discussion in 'PowerPC Macs' started by redraidermacman, Jun 9, 2011.

  1. redraidermacman macrumors regular

    Sep 20, 2007
    I am trying to fix my mother in laws old powerbook G4 so i can give it to my neighbor. The problem I have is that i can't get it connect to my wireless network(airport extreme) it recognizes the network and password but it says connection failed everytime i press ok.... I am at my witts end and i cannot figure this out......any help would be greatly appreciated! thanks
  2. sysiphus macrumors 6502a


    May 7, 2006
    If it's a Titanium model, it has an 802.11B-only Airport card, which means it cannot connect to WPA2 at all, and only can do WPA on Panther or higher. Check these things first. If it's just the WPA2 issue, set the router to WPA/WPA2 dual mode.
  3. jefflamonica macrumors newbie

    Apr 5, 2011
    I've tried this with my PB G4 Ti DVI running 10.5.x. Trying to connect to a Verizon/Novatel 4G MiFi 4510L hotspot. Even when I select WEP on the hotspot, I still get the login failed when attempting to connect through the AirPort menu bar icon. Network preferences panel shows the device until I select the Advanced pane, then it does not show up.

    Is there a third party USB wireless device which will support my PB, 10.5.x and WPA/WPA2?

    Any advice?

Share This Page