Powerbook g4 aluminum won't wake from sleep

Discussion in 'PowerPC Macs' started by capatainreyrey, Aug 6, 2008.

  1. capatainreyrey macrumors newbie

    Joined:
    Aug 6, 2008
    #1
    Recently my powerbook g4 aluminum 15" won't wake from sleep mode, and i can't turn it off with the button. When the computer does turn off the only way i can get it back on is to open it up and reset the logic board by disconnecting the back up battery for a little bit. I've tried reseting the PMU, any help is appreciated.
     
  2. monkey86 macrumors 6502

    monkey86

    Joined:
    Aug 5, 2008
    Location:
    London
    #2
    back up all your data fast! then reinstall the OS

    if this doesnt work either your logic board is fried OR theres a problem with the hardware - but it sounds like a software problem if you can turn the 'book on with the powerbutton.

    k
     
  3. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #3
    I had an issue similar to this years ago with my 12" PB. What I found out was the battery was so old, and had overdischarged messing with the PMU (I think) of the laptop. Is the battery old, such as 4 years old, with a great deal of use? Try keeping the battery out when you start up the computer, it won't mess anything up, and keep it out.

    Also, I'm assuming when you say you can't turn it off with the button, you mean holding the power button down for 5 seconds doesn't shut it off. If this is the case, and the battery suggestion doesn't work, it may be the logic board, or if you're lucky, the DC-DC converter.
     
  4. InLikeALion macrumors 6502a

    Joined:
    Jul 18, 2007
    Location:
    Greener places than I used to live
    #4
    Does it ever "go to sleep" unexpectedly? Because there have been tons of powerbooks with "narcolepsy," suddenly sleeping and not responding to keyboard, mouse, or power button. My wife's did that for half a year - so much that it was unusable. Part of it, we've heard is a faulty temperature sensor which sends faulty "emergency shutoff" temperature readings.

    In an attempt to keep the temperatures from setting off the sensor, we used the powerbook equivalent of smc fan control to keep it cool. This however hurt battery life and still left it useless for audio recording as the fans made so much noise. More drastic steps are available.

    Here are two site dealing with surgery to fix the issue:

    http://knit1spin1.wordpress.com/2007/11/14/narcoleptic-powerbook-cured/
    http://web.mac.com/rickcameron/iWeb/Electric Lamb/N.A.P./9E6BA210-545B-4A66-B57A-A48131342A03.html

    HOWEVER - I didn't have to perform this drastic procedure. I was contemplating it, but they haven't really happened since I installed Leopard. I don't know if that's what fixed it, or if it sort of worked itself out prior to that. All I know is that I keep assuming it will come back, and gasp whenever it doesn't wake up instantly, but it always wakes up.
     
  5. InLikeALion macrumors 6502a

    Joined:
    Jul 18, 2007
    Location:
    Greener places than I used to live
    #5
    Is yours running Leopard? I also still use the fan control out of paranoia, but don't run the fans nearly as fast as I used to.
     
  6. capatainreyrey thread starter macrumors newbie

    Joined:
    Aug 6, 2008
    #6
    thanks a lot for the suggestions. im gonna try to reinstall the OS, im running Tiger.

    It is a really old battery, but i don't think that's the problem because for the past couple of days i've been running it without the battery in.

    i'll post back as soon as i can with updates.
     
  7. YERUBILEE-music macrumors newbie

    Joined:
    Feb 23, 2010
    Location:
    Jerusalem, Israel
    #7
    Hi,

    I'm having "wake from sleep," maybe battery or power supply issues with my mac:

    Machine Name: PowerBook G4 15"
    Machine Model: PowerBook5,6
    CPU Type: PowerPC G4 (1.2)
    Number Of CPUs: 1
    CPU Speed: 1.5 GHz
    L2 Cache (per CPU): 512 KB
    Memory: 1.5 GB
    Bus Speed: 167 MHz
    Boot ROM Version: 4.9.1f3
    Serial Number: YD505473RG3


    The Powerbook will not wake from sleep. I reset the PMU and it still won't wake without a force restart.

    I cloned the drive to another drive, then erased the internal drive and did a clean install, same problem.

    Originally what happened is the Powerbook was unplugged for awhile and the battery became drained. After I plugged it in again, the battery would not recharge.

    It's a "barrel" type charger, not MagSafe - and previously, the charge light was blinking and not making good connection sometimes until I wiggled it.

    Oh, also, it doesn't startup from shutdown with the power button either, unless I reset the PMU.

    Anybody know the problem?

    Thanks,

    Teddy
     

Share This Page