Powerbook G4 Battery/Power Issues...

Discussion in 'PowerPC Macs' started by dsa420, Jul 11, 2009.

  1. dsa420 macrumors 6502

    Joined:
    Feb 23, 2007
    #1
    I have a PowerBook G4 1.5Ghz that has long been suffering from the infamous power issues that have plagued these machines. I have tried all of the recomended steps including PMU and PRAM resets.

    I have 3 different batteries and only one of them will "take a charge", meaning that I don't get the (Not Charging) message on the battery indicator. I took it to a retail store and the not so genius "Genius" thinks something is loose on the logic board, $350 repair charge.

    For some reason this seem like a logical diagnosis. Anyone have any other thoughts on how I could address? Just trying to get this machine in working order to sell, I have a new MBP that replaced this machine.

    Powerbook G4 1.5Ghz processor running Leopard.
     
  2. simonhead666 macrumors newbie

    simonhead666

    Joined:
    Sep 28, 2008
    Location:
    Uxbridge Ontario
    #2
    Same problem.. only with a 17" Powerbook

    Hi
    I picked up a 1.67 lo res powerbook.. Cheap..

    I have the same problem as the above poster only:
    It only starts with the battery in.. the battery charger is orange telling me it's charging.. but it isn't charging. The 'about this mac' tells me that the charger is in but not charging.. the battery percentage drops.. but the energy settings thinks it's running on the charger settings.. When I eject the battery, the laptop shuts off and the light on the charger goes out.. I have to unplug the charger from the wall and them plug it in to get the green light.. when I try to turn it on, I only hear fans..

    I believe that the PMU controller on the board is 'effed

    I have changed the PRAM battery, the ribbon cable from PRAM to Logic board... I have changed the DC board 3 times all with same results.. I know the battery is ok because it works in my Hi res 1.67ghz perfectly

    i have obviously Reset the PMU, PRAM and NVRAM

    My question is.. if the PMU controller on the LB is bad.. would it not see the PRAM battery and not send enough voltage to the logic board to allow it to boot properly with no battery in it (resulting in fan noise) and also would it not allow enough or any power to pass through to the battery but think it's charging

    or am I high?

    any mac wizards advice would allow me to sleep better tonight..
    thanks for reading
    Simon
     
  3. rowsdower macrumors 6502

    Joined:
    Jun 2, 2009
    #3
    My 1.67GHz hi-res PowerBook wouldn't turn on until I replaced the DC-in/sound board. It may or may not have been the same problem, but if it is, it's a cheaper replacement than the logic board. Also, it quit working with similar symptoms about a year after I fixed it.
     
  4. allebone macrumors newbie

    Joined:
    May 29, 2004
    #4
    Are there any generous benefactors that have a spare G4 Powerbook 1.5ghz "PowerBrick" to help a poor military guy troubleshoot the same problem. I am certain I have a bad charger, but I think I also have this problem, but can't narrow it down without a better supply. Willing to pay shipping, just low on funds overall to purchase new or gamble with ebay. I primarily use this machine on my travels which take a newer more functional machine into way more dangerous territory than I would want to for the money, so Im trying to prolong this one however I can...for as long as I can.

    Battery went to junk for a charge a long while back (definitely from use not from any shoddy reason) so the power brick is my only hope (not an intentional Star Wars reference).

    Thank You fellow Macrumors members.
     

Share This Page