Powerbook g4 battery

Discussion in 'PowerPC Macs' started by SCIENTIST29, Oct 13, 2012.

  1. SCIENTIST29 macrumors member

    Oct 13, 2012
    Hi, I bought a used powerbook g4 1,67ghz from ebay. Battery info in system profiler displays very strange information: 65432mah, I have tried reseting the PMU, but that was either unsuccesful or just didn't work. Any ideas? Also the powerbook is terribly slow- scrolling is permanently choppy, loading a web page takes much longer than on my Emac 1,25ghz. Could this be due to small RAM (512mb)? Could reinstalling OS help?? Thanks
  2. cocacolakid macrumors 65816


    Dec 18, 2010
    I don't know about the battery fix, but go into System Preferences, Accounts (or Users), and see what, if any, login items are set to run when the Mac starts up. Select and delete any you don't need. It's possible the previous owner had several things launching at startup.

    But it could also be a failing hard drive.

    To make sure the hard drive is healthy, go to Utilities, Disk Utility, and click on your Macintosh HD on the left, then click on Verify Disk. Do the same for Verify Permissions. If it finds any errors/problems, use the Repair function.

    If all of that doesn't fix your problems, a fresh reinstall of the OS should can't hurt.
  3. SCIENTIST29 thread starter macrumors member

    Oct 13, 2012
    I forgot to mention that the battery doesn't hold more than ten minutes and displays over 400 cycles...
  4. skateny macrumors 6502


    Jul 19, 2012
    New York, NY
    Sounds like it's near dead to me.

    Mine displays 172 cycles. It holds ~40-60 minutes without being connected to the Net.
  5. mike457 macrumors 6502

    Sep 10, 2010
    You don't mention what operating system you are using. If you're running Leopard, the small RAM could easily be the cause.
  6. SCIENTIST29 thread starter macrumors member

    Oct 13, 2012
    Mac OS 10.4.11 is installed, i was planning on installing leopard. I might just reinstall tiger though. I ran all the tests in techtool pro 6 and it showed everything as ok, so I really dont know whats going on...
  7. Hrududu macrumors 68020


    Jul 25, 2008
    Central US
    I'm sure the battery is just toast. I've seen some pretty messed up readings on some of my older portables like that. One of the TiBooks has a higher mAh than it would have had new, but it still works. As for the slowness, 512MB is pretty weak even for Tiger, but it shouldn't be that bad in UI. I would look suspect a failing HDD to cause that sort of issue, but there is no sense in not upgrading the RAM first anyways. Drop the 2GB in there and then see what happens. If you're still seeing that choppiness, then I'd move on to replacing the HDD.

Share This Page