Powerbook G4 can't boot to OS, but clone of HD will boot on another mac??

Discussion in 'PowerPC Macs' started by jimstolz76, Oct 17, 2010.

  1. jimstolz76 macrumors newbie

    Oct 6, 2010
    Got a Powerbook G4 with a "messed up" HD. Couldn't fix it, so got a firewire drive and ran a bunch of utilities from my newer intel iMac. Cloned the Powerbook's drive to a USB hard drive, did all repairs on the USB drive, formatted the Powerbook, cloned the USB drive BACK to the Powerbook, but it just gives me the flashing question mark when I try to boot.

    What is REALLY weird is I can boot my iMac FROM THE CLONE ON THE USB DRIVE and it works fine.

    What am I missing here? I've been working on this freakin laptop for over a week now...:eek:

    In Drive Genius the Powerbook drive (in TDM) shows as a single drive, but if I go to "Repartition" then it shows 3 smaller partitions on the drive; I believe they're called "Apple Free Space" or something like that (can't check right now, I'm running Repair on it AGAIN at the moment).

    I feel like I'm missing something simple, like the machine just doesn't see one thing that tells it "Oh, yeah! There's an operating system on this drive!"

    I have tried partitioning from Drive Genius and Disk Utility. Have done clones back and forth with Drive Genius, Disk Utility, and Carbon Copy Cloner. Same results each time.

  2. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Is your iMac a PowerPC or Intel iMac? What software did you use to clone the PowerBook's hard drive?
  3. 666sheep macrumors 68040


    Dec 7, 2009
    You've probably used wrong partition type, what explains why your Intel Mac could boot from the drive.
    PPC Macs need Apple Partition Map to see drive as bootable. Intel Macs are using GUID (GPT).
    Re-create partition on PB HDD using APM (in DU you'll find it by clicking "Options" button) then do clean OS install.

  4. jimstolz76 thread starter macrumors newbie

    Oct 6, 2010
    That may be it! Forgot about that... that would make total sense.

    I don't have the original install disk, but I will repartition using APM and reclone.


    edit - question, though... what should I use to clone from the USB drive which is (apparently) GUID?
  5. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Do you mean software, if so I'd recommend Carbon Copy Cloner (CCC).
  6. jimstolz76 thread starter macrumors newbie

    Oct 6, 2010
    Actually what I ended up doing was just using Disk Utility and partitioning as APM, then "restoring" from the USB drive, but unchecking the "erase" checkbox so it didn't overwrite anything on the Powerbook HD (not sure if it made a difference or not).

    It worked, and it's sitting here running right now. Thanks a ton for the info. I'm a windows guy, and my intel iMac was my first real mac experience...forgetting something simple like APM instead of GUID is exactly what I was expecting from myself. :)
  7. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Simple mistake to make. Glad to hear that you've got it going.

Share This Page