Powerbook G4: CD Stuck & won't boot

Discussion in 'PowerPC Macs' started by MLSundar, Feb 3, 2011.

  1. MLSundar macrumors newbie

    Feb 3, 2011
    Hello everyone.

    Longtime user first-time poster. So thank you for all your help!

    Was given an old Powerbook G4 15 inch aluminum that someone was going to trash. Being a nerd, i thought I could fix what seems to be a simple problem.
    But I'm stuck.

    So, here are the problems and what I've done to fix:
    Kernel Panic
    • Have copy of boot cd, but another cd is stuck in drive


    CD stuck in optical drive:
    • held down eject button at boot
    • inserted knife, paperclip and cearle box top in drive to stop or grab cd.
    • held option control +o+f and typed eject cd at prompt
    • shook computer to get cd in correct place (in case it wasn't)

    I'm thinking my next option is to open up the computer, take out the optical drive and take cd out...somehow.

    Any suggestions?
  2. chrismacguy macrumors 68000

    Feb 13, 2009
    United Kingdom
    Judging by that the disc has obviously got lodged or stuck on something inside the drive - Id try taking the machine apart, get the drive out and trying to get it out then (If it wont come out just replace the drive - its easier than spending ages trying to get a disc out of an elderly drive).
  3. MLSundar thread starter macrumors newbie

    Feb 3, 2011
    Hi Chrismacguy,

    Thanks so much for your help.

    Question is, if I replace the drive, will the computer recognize the new drive? I must by the exact same one then, yes?

    Also if I take the drive out, how do I get the cd out of the drive? Do I actually have to unscrew the whole thing apart?

  4. chrismacguy macrumors 68000

    Feb 13, 2009
    United Kingdom
    So long as the drive has the same connector it will be fine, it doesnt matter if its the same model or not. It depends, some drives have a little poke hole to get stuff out, or you just unscrew it to get stuff out.
    Chris :)
  5. MacHamster68 macrumors 68040


    Sep 17, 2009
    first try all options even the weird sounding ones like for example conect a usb mouse and press the mouse button hold it during startup and a bit longer sometimes , as the not ejecting could be a faulty keyboard , so pressing the eject button will have no function , but holding down a mouse button might help to convince the drive to eject the disc ,just keep a credit card in hand to push a bit to make clear what you want from it to do :confused:

    ok drives are not expensive but i mean if i can safe a couple quid i will
  6. MLSundar thread starter macrumors newbie

    Feb 3, 2011
    So I have tried everything. NOTHING worked.

    So I've taken it apart and removed the drive.

    Does anyone know if the computer will work if I DO NOT re-install the drive OR Will this screw up the computer even more????

    Thanks so much!!
  7. serial8 macrumors newbie

    Feb 10, 2011

    just unscrew all the screws you have on the drive then remove the disc and put everything back together. Did this a couple times and it works fine.
  8. siwel00 macrumors newbie

    Jun 6, 2013
    no don't open it upon startup hold the right mouse button on your computer until the cd eject and wah lah
  9. ftored macrumors regular


    Dec 29, 2005
    I removed the optical drive from my 12'' powerbook G4 and it is working fine. It was broken anw and i use a powermac G4 to install the OS in target mode:)

Share This Page