Powerbook G4 Dead?

Discussion in 'PowerPC Macs' started by khnlim, Sep 17, 2008.

  1. khnlim macrumors newbie

    Joined:
    Mar 12, 2008
    #1
    Ok. I've tried a search of the forums, and I can't seem to find anyone else with the same problem I'm having. So go easy on me if it turns out that this has been posted before. Here goes.

    The machine I'm having trouble with is a Powerbook G4 17" 1.33GHz with 2GB RAM.

    This machine has been very well cared for. It's mostly been used as a backup machine of late. When I do need to take it out with me, it's transported in a InCase padded Napa leather case.

    I mostly use it plugged into AC, and when I have it plugged in for longer than 24h, I remove the battery.

    It is running for the most part of the day when in use. And when it is in use, it rests on a Cooler Master fan cooler pad to help with the cooling. I just close the lid when I'm done with it. The only time that it is shutdown or rebooted is when an update or installation requires.

    So recently I brought it along to a friend's place, and she borrowed the machine to browse the internet. Being unfamiliar with the sleep function, she shut it down.

    After this, I cannot get it to start up again. Some of the measures I've taken to try and revive it are:

    1. Resetting the PMU (shift-ctrl-option-power, wait 5s, start).

    2. Removing AC + battery and holding power for 10s.

    3. Reseating the RAM (swapping slots, removing one stick at a time, replacing the RAM with the original 512MB stick).

    After all this, I still get nothing. I mean nothing. No chime. No grey screen. No spinning gear. No latch light. No fan. No whirrl-clunk from SD. When I say nothing, I want you understand I'm getting absolutely nothing.

    There is a weird thing though. The battery indicator (5 LEDs on bottom of the battery) work. The AC ring indicate fully charged (green ring) and charging (orange ring). With the AC ring indicating charging (orange ring), and I invoke the PMU reset, it momentarily turns green before resuming on orange.

    I've tried looking high and low for anyone with remotely the same problem, and can't seem to find anything like this.

    As far as I can tell, I think it's either a logic board failure or a PRAM battery failure.

    I'd really appreciate it if anyone has ever experienced this problem and managed to get it solved would chime in with some sort of answer.




    Nicholas
     
  2. applefan1997 macrumors 6502

    Joined:
    Sep 2, 2005
    Location:
    Koreatown, Los Angeles, California
    #2
    It might be a board failure. Are you sure that was all that happened (shut down)? Liquid may have been spilled. I think the battery/power is a bit seperate. The ring glows when it encounters the jack, and it probably directly goes to the battery, when a tiny chip monitors it, which is maybe why it functions. Good luck though, sounds like it was well-treated.

    EDIT:
    I just read another story with a similar sit.: the DC or power module may be fried.
    http://macosx.com/forums/hardware-peripherals/299610-15-powerbook-g4-aluminum-will-not-start.html
     
  3. khnlim thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    #3
    applefan1997:

    Thanks for the reply and the link. In response to your questions:

    Yes it was shutdown. There wasn't a drop of liquid anywhere near the machine. I've never allowed drinking anywhere near this PB, and after reading all the nightmare 'Help-I-spilled-*soda/ OJ/ water/ female juice, etc' threads I glad I'm so pedantic about this. I also have a silicon keyboard cover to guard against FOD by the keyboard.

    I read the link, and while the symptoms are somewhat similar, I am getting the battery charged. I used my friend's PB to check the battery and the AC adaptor, and they both work fine. My PB will charge the battery, just not power up.

    If it is the logic board, then I wouldn't think I'd like to incur the additional expense of having it replaced. But I would like to know for sure. I'm in Singapore, and we don't have Genius Bars, so I couldn't just walk in to have them take a look at the PB.

    If it turns out to be the logic board, then I'd just part out the working components.

    I'd still appreciate any input, or a confirmation of diagnosis, something...




    Nicholas
     
  4. Markov macrumors 6502

    Markov

    Joined:
    May 18, 2007
    Location:
    Philadelphia
    #4
    Well this may or may not be useful for you, and not everything I did you can do... but let me tell you my experience of a machine not starting.

    I have a PowerMac G4 400 MHZ that does not like when it's insides are messed with. When I upgraded the HD and RAM, it would not start up. I had everything plugged in correctly and every time I hit the power button, nothing would happen. What I did to get it working again was this: I unplugged everything from the back, I opened it up, took the RAM out, unplugged everything from the logic board, took out the on-board battery and let it sit like that for about a half hour. After the half hour, I put everything back and the machine started up normally.

    Again, this is a completely different specimen of computer but it's worth a shot. The idea is to completely drain electricity from it. Try taking the RAM + battery out and let it sit for a while, put the ram back, plug it in and try booting.

    Good luck
     
  5. khnlim thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    #5
    Tried that already

    Hi Markov,

    Thanks for the suggestion. I've already tried that and it didn't still didn't work.

    I had to disassemble the PB to get at the PRAM battery module somewhat under the SD. I did leave everything unassembled while I went to search for information on the PRAM battery. Total time unpowered and disassembled, about 30 to 40 mins.

    Anyone else out there had an experience like this? While I don't hold high hopes of getting the PB working again, I would like to get to the bottom of this mystery.

    To applefan1997 + markov, thanks for your input!




    Nicholas
     
  6. Satori macrumors 6502a

    Satori

    Joined:
    Jun 22, 2006
    Location:
    London
    #6
    A friend of mine has exactly the same problem as you with his G4 powerbook and I have been searching around for some possible fixes. The only suggestions that I have found in addition to those that you have already tried are:

    -try removing the airport extreme card (apparently if this is faultly it mimics the symptoms of logic board and/or PMU failure).
    -apply some switch cleaner to RAM connectors before reseating it (although you should get three short beeps if the RAM is bad).
    -giving the machine a little wack on the side where the superdrive is (I'm not sure about this one but I found one tech guy who swears by it - apparently this can re-seat the CPU even though it is soldered :confused:).

    None of these worked on my friend's PB - I hope you have better luck.
     

Share This Page