Powerbook G4 doesn't boot up

Discussion in 'PowerPC Macs' started by JoeyTN, Jan 23, 2008.

  1. JoeyTN macrumors newbie

    Jan 23, 2008
    Got a powerbook G4 that stops at the apple icon screen. Sometimes i get a spinning wheel (not colored) and sometimes i don't. Nonetheless it never gets passed the apple screen. I've tried booting to safe mode, clearing out PRAM (2 cycles), i did cmd-V (verbose) but and it did some stuff but it just kept saying disk error. (that's what it said generally. It was something a little more than just that but anyway), and i've ran disc utility and ran first aid (repaired the hard drive volume which it finished and completed successfully).

    Yet it still won't boot up. Any ideas?

  2. CalMin macrumors 6502a


    Nov 8, 2007
    I don't have any ideas as to what might be wrong, but have to tried Target Disk mode? If that works, then rescue your data and try reinstalling the OS.

    Good luck!
  3. JoeyTN thread starter macrumors newbie

    Jan 23, 2008

    Yeah i've backed everything up already. As far as target mode goes is that hooking it up through firewire? If so then i don't have anything to hook it up to. Should i run diagnostics on the whole computer? Are they any good?

    Anything will help thanks

  4. notengolegs macrumors member


    Dec 17, 2007
    Most likely a failing hard drive. You should try booting off of your OS install CD / DVD or System Restore CD / DVD. If you can boot off of that, then you are likely to have a failing / failed hard drive.
  5. twerk macrumors member

    Nov 13, 2007
  6. QCassidy352 macrumors G4


    Mar 20, 2003
    Bay Area
    ...or do what notengolegs suggested first, and if it's the HD, get a new one for a tiny fraction the cost of a whole new mac.

Share This Page