Powerbook G4 Faulty keys not fixed by replacement keyboard

Discussion in 'PowerPC Macs' started by slipandflo, Oct 25, 2008.

  1. slipandflo macrumors newbie

    Oct 25, 2008

    I have a Powerbook G4 1.6G 15inch. It has a keyboard fault where the '9' 'o' 'L' and period keys are not working. They don't work in OSX OR in Open firmware, which I think rules out any OS issues.

    Things I have tried are:

    1. All usual resets, PRAM, NVRAM, Reset-all etc.
    2. tried external USB keyboard (works fine)
    3. Reseated flex cables
    4. Reseated keyboard connector
    5. replaced keyboard with new part.

    I would guess this only leaves the logicboard? But this seems like an extreme and expensive solution. Before I fork out for a logic board,

    has anyone else come across the same issue, and have a solution?

  2. redaktor macrumors newbie

    Feb 7, 2009
    Did you find a solution?

    I have the exact same problem on my Powerbook, and have done everything but replace the keyboard. Restarting seems to help, as does changing the keyboard language from US to British to Canadian (but that is only short term; I generally end up using the Keyboard Viewer to type in the missing characters after a while).

    Did you ever find a solution long term?
  3. slipandflo thread starter macrumors newbie

    Oct 25, 2008
    Temp fix found kinda

    I traced the fault down to the trackpad/keyboard flex cable. If I pushed down on the trackpad, the keys started working again. As far as I could tell, Apple don't sell a replacement flex cable as it is part of the top case assembly, so I would have to buy the whole thing, which was too expensive given the age of the mac. In the end I tried fitting a shim between the underside of the trackpad and the hard drive which was below it. this worked for a couple of weeks then the fault returned. Now just using an external keyboard. Hope this helps.


  4. redaktor macrumors newbie

    Feb 7, 2009
    Hmm, I'm torn whether this is a software or a hardware issue. After posting I realized that the disk utility app was missing from the Powerbook (I don't use it that often; it's my wife's), so I rebooted with a system disk and ran repair permissions (the one thing I hadn't done). Now, nearly three hours later, the funky keys are still working (before they would stop after about 15 to 30 minutes).

    Maybe that was the problem? I don't know. I always think of repairing permissions as similar to rebuilding the desktop in OS 9: a step akin to pouring holy water on the computer and hoping it would help. In this case, it seems to have done the trick, at least for now.
  5. Ganzolo macrumors newbie

    Feb 9, 2010
    same problem for me...


    I have a power book alu G4 1.33. And some keys on the keyboard doesn't respond in neither OS X and OpenFirmware. And of course I've tried everything (Reinstallation OS X, reset PRAM, reset PMU... etc)

    8 Keys doesn't work : CAPS LOCK, ENTER, [, -, =, \, `, LEFT ARROW

    I've order a new keyboard on ebay... But after reading this post I feel that I've just lost $30.

    Have you find a solution to your problem, Slipandflo?

    And which flex cable are you talking about? The small orange one or the white large one?

  6. edufaria macrumors newbie

    Aug 31, 2010
    Just one key

    My old and beloved powerbook (17"‚ 1.33ghz) has just one key that, suddenly stopped working. It's the delete key.
    I have recently changed the superdrive and the entire screen (do you believe in it?) and, for my surprise, that key came this way. Maybe I could send the computer back to the technicians but, man, it would take forever again and more money. So I think I can try a shot here with you guys.
    Ganzolo, did you fix yours?
    Redaktor, from which application did you run the repair permission, from the disk utility?
    And sorry about the poor english
  7. SparkDawg, Sep 20, 2011
    Last edited: Sep 20, 2011

    SparkDawg macrumors newbie

    Aug 3, 2011
    9ol. problem is caused by trackpad and shim works for me so far


    Wish I'd found this thread a couple years ago. I have the 9ol. problem too and a new keyboard didn't fix it for me either. I never noticed that pushing on the trackpad while hitting the keys makes them work. It's a certain part of the track pad - the lower R. On the back of the trackpad there's an circuit board and at that spot there's an integrated circuit. It makes sense that when you push on the trackpad the board flexes and the chip doesn't so the connections to the chip might crack, creating an open circuit. When you push on the trackpad, you're re-establishing the connection. The IC has factory-applied goo around most of its perimeter, I suspect to protect these connections; maybe it's a manufacturing mistake that it doesn't go around the entire thing. I layered about 7 neatly snipped squares of electrical tape onto the IC to make a shim that bears against the hard drive below to constantly flex the board up and for the last couple hours, my keys have worked. If you do this, use the good kind of electrical tape - 3M 33+ which maintains its integrity at temperature extremes better than the 49¢ per roll kind of tape.

    Cables and wires almost never fail; the terminations do.

    Thanks for the tip and I hope my shim works better than yours.
  8. Tyroler macrumors member


    Jan 2, 2011
    Hatfield, UK
    I have a PPC and sometimes a Key doesn't works or,if i type "T" it write "Y"
    Think its a Software problem,as i swapped the HD from Dual to Single CPU G4 MDD and took the Problem with me.

Share This Page