PowerBook G4 hardware problem?

Discussion in 'PowerPC Macs' started by SCIENTIST29, Dec 3, 2012.

  1. SCIENTIST29 macrumors member

    Oct 13, 2012
    I have a problem with my powerbook g4 1.67ghz. I cant get it to boot past the gray screen after attempting an installation of 10.5. I can boot a different powerbook from this one (target mode), but not visa versa, just get stuck on the gray screen again. I cant install the original 10.3.x, it loads up to the welcome to the mac installer please click continue, but nothing happens. On the other powerbook the disc works just fine. Apple hardware test says everything is ok, so I am confused. What could be the problem?
  2. teleromeo macrumors 65816


    Dec 2, 2006
    kidnapped by aliens
    Not sure about this but I think 10.4.8 is the last Os you can install on a powerbook G4.
  3. simsaladimbamba

    Nov 28, 2010
    Mac OS X 10.4 Tiger went up to 10.4.11 and a G4 PowerBook can run Mac OS X 10.5 Leopard too, hell even my 2004 1 GHz G4 iBook could do that.

    SCIENTIST29, have you tried cloning the working installation onto the other PB via an older version of CarbonCopyCloner or SuperDuper! to see, if that works?

    And the installation media you use, are they grey Restore DVD/CDs or actual Retail versions of Mac OS X?
  4. SCIENTIST29 thread starter macrumors member

    Oct 13, 2012

    I did try copying and that also left me at the grey screen. Installation discs are the grey restore DVDs. Could it be a faulty hard drive? or does that contradict with the fact that i can boot another computer from this HDD?
  5. Zotaccian macrumors 6502a


    Apr 25, 2012
    You have tried those reset methods? PRAM & SMU.

    G4 1.67GHz models had quite much problems with the lower memory slot, I would try to remove ram and/or switching slots depending on what kind of memory configuration you have.
  6. SCIENTIST29 thread starter macrumors member

    Oct 13, 2012
    RAM is ok. PRAM and PMU reset and nothing changed

Share This Page