Powerbook G4 - Kernel errors and random crashes

Discussion in 'PowerPC Macs' started by optimistique1, Jun 15, 2010.

  1. optimistique1 macrumors newbie

    Aug 22, 2009
    Hi All I have a 15" PB Aluminum 1.5ghz with 1GB of ram. Just bought off a friend and when I did a fresh erase and install of OS X 10.4, repaired permissions and rebooted I get the kernel error telling me to hold down the power button and restart. So I did this and when it restarts I get the grey apple background with a load of writing all over it. How do I try and figure out what is causing the problem. I also ran tech tool pro from the DVD and that says everything has passed such as processor, memory etc....

    Also the mac keeps just randomly freezing and crashing all the time. There are no kernel reports but there is a crash report below. I wonder if this could be caused by the RAM. I finally logged into safe mode and it only shows that there is 512MB RAM when in fact there is a 1GB stick of RAM:

    Could all of this be caused by bad RAM and if so how can I be sure?


    Host Name: garry-westwells-powerbook-g4-15
    Date/Time: 2010-06-15 18:55:25.530 +0100
    OS Version: 10.4 (Build 8A428)
    Report Version: 4

    Command: mdimportserver
    Path: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Support/mdimportserver
    Parent: launchd [1]

    Version: ??? (???)

    PID: 460
    Thread: Unknown

    Link (dyld) error:

    Library not loaded: /usr/lib/libcrypto.0.9.7.dylib
    Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
    Reason: image not found
  2. zmttoxics macrumors 65816


    May 20, 2008
    Might be a bad install disk? Have you tried it on another machine?
  3. 4JNA macrumors 68000


    Feb 8, 2006
    looking for trash files

    totally sounds like bad ram to me. several repairs that match the symptoms, every one (except 1) was fixed by replacing the ram.

    the one that i didn't replace the ram on was fixed by pulling the ram, cleaning the contacts, blowing out the ram socket and re-seating the ram. problem solved. you might give it a go if you are handy with hardware. best of luck.
  4. optimistique1 thread starter macrumors newbie

    Aug 22, 2009
    I had a feeling that it may be the RAM but wasn't sure. I have tried the install DVD on other machines with no problems. I wonder why Tech Tool Pro didn't pick up the bad ram and why does it show 1GB in normal mode and 512NB in safe mode - very weird!
  5. deangordon1 macrumors newbie

    Jun 22, 2010
    I have same problem

    I have similar issues.
    I have a powerbook g4 17-inch; 2 gb ram; I have erased hard disk with the 7-pass option. COMPLETELY ERASED several times; re-installed the 10.4 software, ALLOWING IT to check the install disk. I install and it crashes almost immediately, telling me to power down with the power button and restart.
    I have brought it in for service and they have done diagnostics on all the hardware and it passes the diagnostics. I have done the same at home: PASSES ALL HARDWARE DIAGNOSTICS;

    Another problem, PROBABLY NOT RELATED, BUT I DON'T KNOW; the AIRPORT CONNECTION GOES ON AND OFF at intervals of about 2 seconds. for 2 seconds, i have full bars and am connected, then for 2 seconds, it disconnects and no bars.

    It's VERY close to becoming a boat anchor. Any ideas?
  6. optimistique1 thread starter macrumors newbie

    Aug 22, 2009
    The causes of my problems turned out to the RAM. I bought new RAM from crucial and as soon as I installed it all the problems disappeared so that could be the same for you if you recently bought RAM. Maybe your airport card has come lose also...
  7. deangordon1 macrumors newbie

    Jun 22, 2010

    Thanks very much. I'll give it a try. Any thoughts on what you use to clean contacts on RAM? Alcohol?
  8. 666sheep macrumors 68040


    Dec 7, 2009
    Isopropanol is the best for contacts cleaning.

Share This Page