Powerbook G4 Keyboard problem

Discussion in 'PowerPC Macs' started by Jtsnider, Jan 15, 2008.

  1. Jtsnider macrumors newbie


    Jan 15, 2008
    Houston, TX
    Hello all

    I've searched this forum and found numerous threads addressing this issue, and I've tried a variety of things.

    First, the problem: Backlit keyboard doesn't work. F8,F9, and F10 keys don't work either. At first it using the F# keys used to tell me that I couldn't adjust and now they don't prompt an icon at all. Also - going into preferences and trying to turn on the "illuminate keyboard in low light conditions" used to always be checked even though the keyboard wasn't lit, and now that option in my preferences under the keyboard section is gone completely!?!?

    Also, I downloaded "labtick" which is a freeware software designed to allow you to always have control over your backlit keyboard. When I try to launch that program - it says my cpu doesn't seem to have a backlit keyboard.

    Just to clarify - I have a 1.67 Ghz processor G4 running Tiger with 2 GB's of RAMM.

    I do have the backlit keyboard icons on my notebook. The back-light keyboard worked for the first year and half of use.

    Also: I tried using Disk Utility and repairing disk permissions. Restarted and nothing.

    Also: I tried resetting parameters - holding down Command, Option, P and R on startup. Still nothing.

    I am at a loss.

    I even tried deleting the library>preferences> com.bezelservices.plist

    still nothing

    Please help

  2. goundry macrumors newbie

    Jun 1, 2004

    Yeah, this is indeed an odd and well discussed topic, of which i'm also affected. I have a 1.5 15" PB with 1Gb RAM and have had this problem for a long time - i just haven't cared enough to investigate or speaking to Apple. However, now's the time as i need it now.

    A little of my history:

    * In the beginning, all worked well (for a year or so after purchase), with options available in the control panel to enable & disable backlight support and functioning F8 to F10 keys
    * Then, for the next year or so, the keyboard keys F8 to F10 did display onscreen messages on selecting them, but the onscreen graphic displayed a cross through it, suggesting that the backlit keyboard wasn't available. For this time, the options remained in the control panel to control the backlit keyboard.
    * Now, the F8 to F10 keys do not display anything onscreen - they are basically dead. Also, the option in the control panel has gone to enable / disable the backlit keyboard AND so has the option in the 'Display' control panel to enable / disable varied brightness based on room ambient light. Plus, i just tried the 'Lab Tick' app and it confirms that i don't have a backlit keyboard.

    How very odd! I have to speak to Apple about this very odd situation.

    Please let me know if you find a resolution :) I'll do the same

  3. goundry macrumors newbie

    Jun 1, 2004

    I followed the following advice to reset the PRAM and it worked


    I simply:
    * Switched off the mac
    * Held down the Command, Option, P and R keys and pressed and held the power key. The mac started and i kept all buttons held until i heard the chime. I then released them all and on booting of OS X, it worked as it did before!

    I'll see how long it lasts.

    Hope it works for you too.
  4. petersmarty macrumors newbie

    Mar 14, 2014
    A note about the PRAM-reset procedure

    Hello all,

    I, too, got my keyboard problem fixed, and, indeed, resetting the PRAM did the trick. However, I would like to note that it is necessary to hold down the "power on" button along with the other 4 keys until after the regular "boot up" chime sounds. This regular 'boot up" chime follows another "tone" that I had never heard before and presumably is part of the PRAM reset sequence.

    I was perplexed by the PRAM-reset instructions, which mentioned that the keys had to be held down until after the 2nd chime. The first time I tried this, I heard no 2nd chime. Where was the 2nd chime, I mused? When the problem was not solved, I went searching again, and, thanks to goundry, I realized that you have to hold down the power-on button, too. Doing so, then I heard the fan, the tone, and then the regular chime.

    I will just mention, for what it's worth, that my crazy-keyboard problem has cropped up irregularly for years. In the past, I unplugged the computer, removed the battery, and this action always solved the problem. However, today, I repeated that sequence multiple times to no avail. Now I believe I have the "real" method for solving this keyboard problem.

    The problem is solved, and I thank you all.

Share This Page