Powerbook g4 (last model before intel) kernel panic, please help

Discussion in 'PowerPC Macs' started by stege, Sep 7, 2010.

  1. stege macrumors newbie

    Oct 15, 2009
    Hi everyone
    I have a BIG problem with my old powerbook.
    I have decided to format it.

    It came with tiger, I had installed leopard with an upgrade DVD (not full version).

    What I did: I inserted the leopard upgrade dvd and told the pb to initialize and install. After a while I had an error message.
    It already deleted everything, so when I insert the leopard dvd, it doesn't find any other OS, therefore I can't install the upgrade.

    NO PROBLEM, I have the 2 tiger DVD.
    I insert the first one, pressing C, no. It does not start.

    NO PROBLEM, I connect via firewire the powerbook to a macpro. I open the cd 1 of tiger (in the macpro) go to the installation file, and start the installation via firewire. It tells me that I have to partion the disk in Mac os extended with an option "GUI" (something like that).

    [note: i have noticed that the GUI mode is for an intel based mac, but mine is ppc...but if I select any other option the system doesn't allow me to continue with the installation of OSX]

    I did it, and the installation proceeded well.
    After a while It asked me for CD2, I inserted it and finished the installation succesfully.

    Now I started my powerbook...and is not working, again Kernel Panic...but now there is the OS installed, so...why????

    What did I do wrong?
    I post the picture of the screen

    I really need help, please any idea is wellcome
    thanks a lot
  2. stege thread starter macrumors newbie

    Oct 15, 2009
    I've seen I should partion it as "apple partiton map" since is a ppc

    But is not working, it asks for GUI

    But with GUI is not starting.

    I've just tried also to start the pb with Tiger installed (but not starting) and the cd of leopard (upgrade) insert.
    Now it finds the OS tiger, so I can proceed with the installation, but now
    it tells me I have to partion the disk as "apple partiton map" in order to proceed :confused:

    arghhhh :mad:
  3. Giuly macrumors 68040


    Insert the Leopard-DVD in the PowerBook, boot it while holding the "C"-key, wipe the hard drive via Utils->Disk Utility in the top-menu, choosing your hard drive and click "Delete". Do a clean install then, even if it's an update DVD, you don't have to install Tiger first.

    Tiger is either one DVD or four CDs, btw. I guess you have something weird like Restore-DVDs (The gray ones) from an Intel-Mac or something - which don't work on PPC:
    And for the GPT vs. APM: On an Intel-Mac, you can only install to GPT formatted disks, while on PPC you can only install on APM formatted disks. Either you get another PPC machine and install via Target Disk Mode from it, or you have to boot a DVD on the PowerBook.
  4. stege thread starter macrumors newbie

    Oct 15, 2009
    thanks for the advice, I'm going to try it right now.

    I didn't know that I could install the OS on a ppc only from a ppc and not from an Intel :(

    The tiger cd I have is in 2 dvds that came with the pb:
    "Mac OS X Install Disc 1" version 10.4.10
    "Mac OS X Install Disc 2" Disc version 1.0

    But you are right, I've just realize they are from the Macpro intel...I think I've lost the original cd from the powerbook

    What I'm doing now is:
    Connect via firewire
    Format the HD as GUID
    Install OSX tiger (wrong cd)

    It will not start, but at least Leopard will be able to detect Tiger as installed.
    then I'll try your tips, erase from the disk the HD and proceed with installation.

    I hope it works, I'll keep you updated
  5. MacHamster68 macrumors 68040


    Sep 17, 2009
    you did it the wrong way round i suppose
    yes , you can put the tiger disc into the Macpro , connect via firewire with the Powerbook , but you need to boot the macpro in target disc mode and the powerbook press the powerbutton and exat at the same time holding down option key for a long long long long time until it sees the macpros optical drive , so the powerbook where you want to install tiger to will notice the macpros optical drive like a external connected via firewire

    if you boot the Powerbook in target disc mode the macpro gets confused and thinks you want to install tiger on it on a external harddrive thats connected via firewire and that does only work in gui because the macpro is intel , thats why you dont get
    "mac os extended journaled "( apple partition map)as a option ,but you dont want tiger on your macpro

    dont worry i once did the same mistake the other way round i did want to install from a eMac to a intel iMac ,but the iMacs optical was removed and replaced with a ssd
  6. stege thread starter macrumors newbie

    Oct 15, 2009
    Thanks for the info.
    If I have no success with the procedure I'm trying now I will try as you said.
    Could you please explain better the procedure, I didn't understand how to start the macpro and the pb...
    I start the macpro pressing T AND in the same moment I start the pb pressing the option key for the long long (long) time. Is that right?
  7. stege thread starter macrumors newbie

    Oct 15, 2009
    :( Ok, I've tried with Giuly's method, but didn't work.

    Once I started the computer with leopard insert he told me I had to initialize the HD as apple partition map.
    I did it and it proceeded with the installation.

    I was hoping that everything now was fine, but I was wrong.
    After 20% of installation, a message appeared:
    You need to restart your computer.

    And that's it.

    I've restarted, and now is asking for OSX tiger before proceeding.

    NOw I'll give a try to MacHamster68 method.
    sigh :(
  8. MacHamster68 macrumors 68040


    Sep 17, 2009
    hello not al at the same time, first connect the two via firewire , put the disc in the macpro , then shutdown and restart the macpro by holding down the T until you see on its attached screen the firewire symbol which means its in target disc mode , now shutdown the Powerbook and hold down the option key at the same time you restart, it takes somtimes long before its realising that there is something via firewire attached so keep holding that option key (if i do it on my eMac it takes a good minute or even more before the attached firewire drive show up) because the powerbook looks first around all internal options before it takes a guess and looks for external devices to boot from

    but now your powerbook should see a optical drive with the tiger disc and you should be able to select it as startup and the install process should
    if it does't then i assume there is a problem with your powerbook
  9. stege thread starter macrumors newbie

    Oct 15, 2009

    Ok, nothing is working :(
    I've tried MacHamster68's method.

    I started macpro as target (with osx tiger dvd insert inside)
    I've started pb pressing option key.

    Then I had two choices: Start pb with the dvd inside the macpro, or start the pb directly with the hd of the macpro.

    If I choose the dvd, is not working...kernel panic as before
    If I choose the hd then the pb is starting and acutally i see al the file like I am in the macpro.

    Then I launch the dvd with tiger installed, it starts and immediatly it stops, telling: "alert: you can not install this software in this computer"

    that's all.

    Last chance is to find a tiger or leopard "full" version, not linked to any computer, and try to install directly from that. S**t!

    EDIT: simoultaneous posting :p Thanks anyway for your help!!
  10. stege thread starter macrumors newbie

    Oct 15, 2009
    That's cool :cool:

    This tecnique is working. Now I can install directly via the Leopard upgrade dvd...but at some points it ends.
    It says the cd is somehow corrupted :confused: (strange, because it's like new -.-)

    I will try to find another copy of leopard and start again...
    thanks anyway :)
  11. CubeHacker macrumors 65816


    Apr 22, 2003
    Sounds a bit like a hardware problem to me. The string of kernel panics does not sound normal - especially during installation. The Installation is supposed to do a full scan of the disc before installation begins (usually called verifying disc) before it starts copying files to make sure the disc isn't damaged. If it passes this check, then the disc should be fine. I believe something else is going on.
  12. MacHamster68 macrumors 68040


    Sep 17, 2009

Share This Page