Powerbook G4 problem, diag. help!

Discussion in 'PowerPC Macs' started by serial8, Feb 10, 2011.

  1. serial8 macrumors newbie

    Feb 10, 2011
    So, first post, new Mac user. But I'm a Professionnal PC tech so.. shouldn't be a problem with technical stuff.

    Just got this Powerbook G4 1.67Ghz 17po 2x512Mb model A1107......

    The was no OS in it so I had this folder+? kind of thing showing up. Tried a OS 10.4 disc but did a kernel panic... so I downloaded a 10.5 Leopard disc to try it.

    In the meantime.... No more display on screen, the Tiger DVD was stuck in the drive.. eject or trackpad button did not worked to get it out. Dismounted the PB to get it out of the drive than remounted all up.

    Still the same problem though. Cleared the NVRAM, tried safeboot, tried resetting the PMU, tried removing RAM sticks, alternating each other in each slot alone or not. Checked every connection on the board. Tried without the Superdrive plugged in. Tried on another screen. Nothing.

    So... I hear the chime, the Superdrive spinning, the fans turn normally. No KB backlight, no apple on the lid and no led in the front lit up though...

    Any ideas?
  2. OrangeSVTguy macrumors 601


    Sep 16, 2007
    Northeastern Ohio
    Try to restore the Leopard CD to a firewire HDD and try booting from that? Or target disc mode if you have another Mac. Could be a dead superdrive.
  3. serial8 thread starter macrumors newbie

    Feb 10, 2011
    Wouldn't it give me something if I uplugged it? I tried it and it doesn't work. Or maybe it absolutely needs one...

    Maybe I can try to find another mac...

    What I don't get is the no video thing. Would a dead superdrive give me no video at all?!

Share This Page