Powerbook G4 RAM beeps

Discussion in 'PowerPC Macs' started by ytty, Aug 26, 2010.

  1. ytty macrumors newbie

    Joined:
    Aug 26, 2010
    #1
    Just replaced the logicboard on a 01' Powerbook G4 Titanium Onyx and I'm getting the no video/beeping sound after the chimes upon power up.

    3 beeps
    3 lights (1 long + 3 quick flashes)

    I don't THINK it's the RAM though, I thought these cards were good before the computer fried. I've swapped the two 256MB cards with each other, also plugged just one RAM card in both slots one at a time--still no turn on and I get the 3 beeps. Unfortunately I don't have any extra 144-pin 133 Mhz SDRAM chips laying around or i'd just test them. It seems unlikely that both RAM cards would be broken, in addition to the logicboard frying, unless the two events happened simultaneously. Previous install had the 667 Mhz upgraded processor and when I took the logic board out it was fried on the bottom with lots of corrosion/leakage on a good 5% of the surface area. Anyways, I replaced it with a 550 Mhz board. Could the beeping be from installing the different processor or is it more likely that I simultaneously fried both RAM chips plus the motherboard?
     
  2. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #2
    http://support.apple.com/kb/HT1547

    Here's the deal 3 beeps means your banks are no good. Link above is the support document for that very issue.

    Best of luck.
     

Share This Page