PowerBook G4 RAM problem

Discussion in 'PowerPC Macs' started by Kopachris, Feb 22, 2007.

  1. Kopachris macrumors newbie

    Feb 12, 2007
    under your bed
    When my dad got this PowerBook G4, it came with 1Gb of ram. Later, he bought 2Gb (2x1Gb) and put it in. It locked up all the time. I'm not sure on the specifics. Anyway, he took it out before they came out with the AirPort update, so when I got it, I put the 2Gb back in, thinking that the AirPort update would fix the lockups (It was supposed to fix some problem with having more than 1Gb). It didn't work. Now, every night, while I play my music to help me go to sleep (AC/DC + Fast Car = Fast Asleep), it locks up, making a ch, ch, ch, ch... sound that wakes me up. When this happens, nothing short of holding down the power button will work. Also, sometimes my Bluetooth Mighty Mouse loses the connection for no reason (while I'm moving it). When I go up to the Bluetooth menu, it pops up with its "You need to restart your computer" message. Sometimes, it just freezes. None of this happened before I put the 2Gb in. I've searched all over the place for answers. Is the only way to fix this to take out the ram and switch it?
  2. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    OK, well the obvious answer would be that one of the 1 Gb modules (or rarely, both) is either defective or is not compatible with the machine.

    The first generation AlBooks (1.0 - 1.33 GHz) are notoriously finicky about getting RAM with the right SPD settings AND compatible with slewing. Generic PC RAM, Kingston ValueRAM or whatever will NOT work in these machines.

    You should be able to send the RAM back under warranty --it's not gonna get fixed with a software upgrade.

    What RAM is it exactly, and where was it purchased?
    What model and speed of Powerbook is it - the one in the sig?

  3. Kopachris thread starter macrumors newbie

    Feb 12, 2007
    under your bed
    Yeah, it's the PB in the sig. Each of the modules' size is 1Gb, type is DDR2 SDRAM, speed is PC2-4200S-444, and the status of it in the system profiler is OK. i have no idea where he bought it, but it might have been from ZipZoomFly. He does a lot of business with them. I guess this weekend I just have to take it out. It worked fine with the 1Gb. The only need for the 2Gb was for pride pretty much. Thanks for answering my question!
  4. dshootist macrumors member

    Feb 4, 2005
    I found this on OWC's site when upgrading my RAM...

    I've got the 15" 1GHz AI G4 PB and just upgraded my RAM to 1.25GB (great price, by the way). They posted this in one of the chip descriptions:

    The following applies ONLY if selected memory is to be utilized in a Apple PowerBook G4/1.0 or 1.25GHz FW800 Model.

    For those with PowerBook G4/1.33GHz and faster or iBook G4s - the following does not apply. It only applies to PowerBook G4 1.0GHz / 1.25GHz FW800 machines.

    OWC has determined that an unknown amount of PowerBook G4 15" FW800 Models with 1.0GHz or 1.25GHz Processor speed, have a memory controller issue that significantly restricts the memory compatibility. There is no way to pre-determine if your PowerBook G4 will have this issue, but if you are upgrading a PowerBook G4 15" with 1.0GHz or 1.25GHz G4 Processor Speed, this possibility does exist. No other PowerBook/iBook model or speed is subject to this memory controller issue.

    Although you still may continue with the purchase and try the module selected, we do recommend the Factory OEM Samsung PC2700 Module available by clicking here. Should you purchase the selected module and have an issue, you do have the option to exchange for the Samsung within 30 days for the difference in current price plus freight charges.

    After testing with other Factory Original as well as Major 1.0GHz or 1.25GHz processor. This is not an issue with the quality of the modules tested and all OWC memory is of Top Quality, meeting or exceeding Apple specifications, and backed with a Lifetime Advance Replacement Warranty as well. We believe the problem is related to a memory controller that was used in some 1.0GHz or 1.25GHz Powerbook G4 systems that has a specific tailoring to Samsung die/pcb memory. And this is why, regardless of specification - only specific Samsung modules provide operational compatibility.

    You did not mention whether you have the 15" or the 17" so I hope this helps...
  5. Kopachris thread starter macrumors newbie

    Feb 12, 2007
    under your bed
    I saw that on google. Doesn't apply to me. I'll just switch it back to the 1Gb tomorrow. Like I said, putting the 2Gb in was just for pride. It worked fine with 1Gb.

Share This Page