Powerbook G4 Superdrive won't accept discs

Discussion in 'PowerPC Macs' started by anthrodora, May 1, 2008.

  1. anthrodora macrumors newbie

    May 1, 2008
    Oregon, US of A
    Hi all! I know there are lots of problems with superdrives, and I hate to ask a redundant question but I haven't found anything that helps yet in searches, so I'd appreciate your patience and assistance.

    There's no disc in the drive, but it's locked up and won't accept a disc into the slot whatever I do. It never had trouble reading discs before--none of the spinning-without-reading issues I'm seeing other people have had. I have frequently ended up with ghost discs, when the computer hangs onto a disc image (or two) after ejecting the actual discs, but it's never caused a real problem. There is no disc image now.

    She is an old lady of a 12" titanium Powerbook G4. 867 MHz, 640 MB ram, running Panther 10.3.9. The drive in question is the original apple-shipped MATSHITA DVD-R UJ-815. Pushing five years, we are long past warranty/Applecare here.

    What I've tried:
    Pressing eject (ad nauseum)
    Pressing F12
    Command E
    Pressing eject in iTunes
    Adding an eject button to the toolbar and pressing that
    Checking in About This Mac>More Info that the device is still recognized (check)
    Restarting (several times)
    Shutting system down overnight and rebooting in the morning
    Going into Open Firmware and typing command "cd eject" (says "can't OPEN the EJECT device")

    What I know of but haven't tried:
    Restart holding mouse button - I don't have a USB mouse on me.

    Hoping I don't need to take it in or get the drive replaced--no way I'm opening this sucker up myself, though.
  2. merl1n macrumors 65816


    Mar 30, 2008
    New Jersey, USA
    Try a PMU reset, PRAM reset and Safe Boot. Otherwise, if there is no disc in the superdrive, the superdrive may be dead.
  3. CaptainChunk macrumors 68020


    Apr 16, 2008
    Phoenix, AZ
    Sounds like you have a dead SuperDrive.

    Opening up the 12" PBG4 is a PITA because you have to take apart just about everything, but I had to do it to replace my SuperDrive that was out of warranty.

    ifixit has an excellent step-by-step guide for this procedure. They also sell replacement drives for your baby.
  4. bkdolan macrumors newbie

    Aug 18, 2006
    Rome, Italy | Ann Arbor, MI

    Were you ever able to resolve this? ... and if so, what did you do?

    Was it dead?
  5. iThinkergoiMac macrumors 68030

    Jan 20, 2010
    FYI, for those reading this... you don't need a USB mouse to use the hold mouse button to eject feature as the OP seems to think... the trackpad button works perfectly fine (and would likely have solved the OP's problem).
  6. anthrodora thread starter macrumors newbie

    May 1, 2008
    Oregon, US of A
    Yes, sorry for not posting the result--I ended up taking it in to my local mac retail/repair shop, and apparently they just jammed a disc into the drive past the resistance, and it worked fine. Very anticlimactic.

    I was not able to override the superdrive using the trackpad to mouseclick-restart. Maybe I was just not timing it right, but it was not working and information I found online supported my understanding that this procedure required a usb mouse. However, perhaps in my case it was a mechanical issue which the mouseclick wouldn't have helped with in any case.
  7. iThinkergoiMac macrumors 68030

    Jan 20, 2010
    You hold the mouse button as soon as you hear the startup chime. In any case, it works fine on my PBG4 and I don't even have the USB-based trackpad (introduced in the last generation of the PBG4).

Share This Page