Powerbook G4 Turns Off When Battery Charger is Unplugged

Discussion in 'PowerPC Macs' started by oneclassybroad, Jun 20, 2005.

  1. oneclassybroad macrumors newbie

    Jun 20, 2005
    My Powerbook G4 only turns on if the battery charger is plugged in, and if I unplug it, the computer shuts off. On the menu bar, it says charging. I know the battery has to be full. This just started happening last night. Also, I just had the hard drive replaced and I've only had it back for a couple weeks. Does anyone know what the problem could be?
  2. ericssonboi macrumors 6502

    Mar 15, 2005
    Are you sure your battery isn't dead? It seems like its not...
    And it seems like your computer is pretty new...
    Only thing that does come to mind is that the connection of the battery might be loose or your battery is dead.
  3. ITASOR macrumors 601


    Mar 20, 2005
    Try taking the battery out and cleaning the contacts on both the inside of the computer and the battery. You never know...
  4. aussie_geek macrumors 65816


    Apr 19, 2004
    Sydney Australia
    Try this

    Have a look to see if the battery is really charged. Even though the PowerBook can tell you this, there is a manual way to do it also. You can do this by pushing a little silver button on the battery. There are green lights that will light up to show the amount of charge in the battery. If the lights are all lit, call Apple and explain about the new hard drive install and the battery problem you are having.

    If none light up - your battery is not being charged. Try a PMU reset and re- charge the battery.

    PowerBook G4 (15-inch 1.67/1.5GHz), PowerBook G4 (17-inch 1.67GHz)
    PMU reset sequence:

    If the computer is on, turn it off.
    Disconnect the AC Adapter and remove the computer's battery.
    Press and hold down the power button for 5 seconds and then release the button.
    Reconnect the battery and AC Adapter.
    Press the Power button to restart the computer. Charge the battery and see it that rectifies the problem.

    If that doesn't work, a call to Apple would be in order.

  5. DanielleInTulsa macrumors newbie


    Aug 25, 2008
    Tulsa, OK

    aussie_geek, thank you!

    i was having the same problem with my new(er) macbook and your steps for the PMU reset worked!
  6. esspee1200 macrumors newbie


    Nov 18, 2007
    Bay Area
    i am experiencing the same issue.

    basically, my battery is 100% charged per the menu bar on the top right. but, when i unplug the ac adapter, the powerbook shuts off immediately.

    i have a new 3rd party battery. it worked perfectly fine and then...baaam!!...now this.

    i called apple care and they said that i might need a new battery. i don't believe what they are saying since this is brand new and it used to work like a charm until as of recent.

    any help?
  7. Kwalla73 macrumors newbie

    May 30, 2010
    PowerBook G4 1.67ghz 15" menu 100% but no charge???

    My PowerBook G4 1.67 GHz 15" running 10.4.11 menu shows 100% but when I remove the adapter there is no power and it shuts off immediately. The battery doesn't show any evidence of charge when I press the battery charge status button. What gives? The leads connecting the battery to the computer appear clean. Has the battery kicked the bucket?
  8. g3powerbook boy macrumors member

    Jan 29, 2010
    I just bought a g4 powerbook last night off of craigslist the person that had it said the battery is finished only thing wrong with it was the battery. today i found the same g4 powerbook battery on craigslist for $ 15.00 went and bought it brought it home and it didnt want to charge until i reset the pmu. my suggestion would be to try to reset your pmu as explained above.

    good luck.

  9. Kwalla73 macrumors newbie

    May 30, 2010
    In all my tinkering, I found another problem. My pram battery is dead. I can tell because the t&d keep resetting to Wednesday, December 31, 1969. Now, I don't know if this has anything to do with the battery charge, but I saw a pram battery online for $49, so I'll give that a try first, then I'll get back and report my findings.

  10. g3powerbook boy macrumors member

    Jan 29, 2010
    I'm not real sure that the g4 powerbooks have a pram battery like the g3s did. and if they do... it sure isnt under the keyboard like it wasin my g3 powerbook pismo which i still have as well as my new g4 titanium i bought last weekend. I think the time and date read off of its main battery which tells me it isnt charged, however i could be wrong but my g4 powerbook titanium reset the time and date until i changed the battery with a known good used one and it has not reset its time and date yet. I would try resetting the pmu as mentioned first before buying a part you may not need let alone have. maybe see if you can find a known good battery and see what it does as well.


Share This Page