PowerBook G4 wifi problems? Help?

Discussion in 'PowerPC Macs' started by xDLiam, Dec 20, 2009.

  1. xDLiam macrumors newbie

    Dec 20, 2009
    Hey, I bought myself a PowerBook G4(FW800 1GHz 15") the other day, because I haven't got the cash for a new apple computer. Anyway I set it all up and that, then I went to connect to my wifi(netgear) and I put n the password(which was correct) then I got a message saying 'cannot connect to airport network 'NetGear' ' or something like that anyway. Yeah so that's my problem, also when I tried connecting to it in other ways it said my password was incorrect but it wasn't.

    I've been searching for the past couple of the days if there is anyway to fix this but I haven't found any solution.. I've notice loads of other people have had this same problem! It's really annoying. And to be honest I'm not a computer wiz at all, so if anyone is kind enough to help please make it easy? Oh yeah I have an airport extreme card and a Netgear WGR614 router. I know it can't be the routers fault because we have 3 other pc laptops that are connected no bother, a ps3 connected with no bother and two iPhones connected with no problem..

    I really really want some help with this?. Thank you so much in advance!.
  2. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    What Mac OS X version is on that computer?

    Go to the :apple: on the top left, select About this Mac.


    If it is older (<10.3.3) it might have a problem with the router.

    Also have you tried connecting to the router via an ethernet cable and checked what settings the router has?
  3. jodelli macrumors 65816


    Jan 6, 2008
    Windsor, ON, Canada
    I'm not familiar with Netgear other than the ethernet switch I have.

    However I have had to drop the MAC address filtering temporarily on my D Link router to 'let in' a computer or two at times.

    BTW, I have both Airport Extreme and Ethernet active on this particular computer which is also a 15" G4 (last gen)

    Your Network setting look something like this>

    Attached Files:

    • w.jpg
      File size:
      54.2 KB
  4. xDLiam thread starter macrumors newbie

    Dec 20, 2009
    I'm running on Panther 10.9 I do plan to ugrade but not atm maybe late January. And I don't think it's anything to do with letting another computer in and my settings don't look like that, well they do but they're blank with no addresses in.

    I've tried my pb through Ethernet and it worked fine and connected to the Internet, but I haven't connected my router to my pb because I only have one Ethernet wire wich is connected to the modem and I thought that if I disconected it from the modem and into my router it'd just be connected but the Internet wouldn't work and that I wouldn't get any addresses? :S

Share This Page