Powerbook G4 wont boot.

Discussion in 'PowerPC Macs' started by thejollyfatman, Sep 10, 2009.

  1. thejollyfatman macrumors newbie

    Oct 24, 2008
    Right, i have a Powerbook G4, that was running OS X 10.3. I wanted to upgrade to 10.5. I've checked the specs and the powerbook is capable of running Leopard.

    The Powerbook said that 10.5 couldnt be installed. So i decided to install 10.4 and use a 10.5 upgrade disc i got with my Aluminium Mac.

    10.4 required the disc to be reformatted with a GUID Partition Table. So i did that and tried to install 10.4. But it wouldnt read the disc. So i connected it as a Target Firewire drive to my Mac, and installed it from there.

    The Install succeeded. But now when i boot the Powerbook all i get is a folder with a flashing question mark in it. And it wont go any further. BUT, i cn boot my iMac from in 10.4 using the Powerbook as the startup disc.

    Could there be a problem with what would be the equivalent of a BIOS?

    Thanks for any help you can give.

    P.S. Ive tried booting from a cd, clearing the PVRAM, both to no avail.

Share This Page