Powerbook G4 won't start up. Help!

dionido

macrumors newbie
Original poster
Sep 3, 2007
4
0
Yesterday evening I normally turned off my Apple Powerbook G4, and today when I tried to turn it did something pretty strange...
I could hear the internal fan go on, and the light clicking sound that means the computer is working, but nothing appeared on the screen; it remained completely dark. The LEDs of the cap lock and num lock are active, as are the battery indicators lights on the bottom side of the laptop, but otherwise I can't get any reaction from it. I tried shutting it down (I had to actually remove the battery to do so) and rebooting OSX from the installation cd, but the only thing that I gained was that now the cd is stuck inside and no progress was made! :(
I also tried booting it in firewire mode while connected to my iMac (via firewire cable) but again to no avail...

I'm really not a tech guy so I don't know what else to try... has anyone else had this problem? i can't find anything on the net about this particular problem...

thanks!
 

teleromeo

macrumors 65816
Dec 2, 2006
1,285
34
kidnapped by aliens
looks like the screen is dead or it starts up thinking the lid is still closed.
Leave the lid open, hit the power button and enter to shut down and hit the power button again.
 

sabr

macrumors newbie
Jun 30, 2007
17
0
new york city
i've been having this same problem for months now, and i believe it's a common problem with older powerbook G4s.

my temporary solution is to reset the PRAM and NVRAM, as an earlier poster said. although, sometimes, i have to reset it more than once to get the screen working.

my applecare ran out before i started getting these problems, and so i never got it serviced.

if anyone has any permanent solutions or fixes, i'd be very interested to know :)
 

dionido

macrumors newbie
Original poster
Sep 3, 2007
4
0
mmm

no no power shortages.... anyway i tried the NRAM etc... but nothing worked! btw, i don't think it's just a screen problem, because even though the cpu does appear to be on, it doesn't react to force shutting down (power button held down) or other commands that would work if it were truly running...

hmm
 

dionido

macrumors newbie
Original poster
Sep 3, 2007
4
0
..

i've been having this same problem for months now, and i believe it's a common problem with older powerbook G4s.

my temporary solution is to reset the PRAM and NVRAM, as an earlier poster said. although, sometimes, i have to reset it more than once to get the screen working.

my applecare ran out before i started getting these problems, and so i never got it serviced.

if anyone has any permanent solutions or fixes, i'd be very interested to know :)

so far it isn't working for me, but i'll keep trying... i hope it'll work!!
 

dionido

macrumors newbie
Original poster
Sep 3, 2007
4
0
nothin

so far it isn't working for me, but i'll keep trying... i hope it'll work!!
i've tried again and again, but nothing happens. I don't even hear the startup sound... and every time to turn the cpu off i have to take the battery out, because the power button works only to turn it on! :mad: