PowerBook left unused no longer works

Discussion in 'PowerPC Macs' started by tom.g.coleman, Mar 21, 2007.

  1. tom.g.coleman macrumors newbie

    Mar 20, 2007
    Seattle, WA
    Please help with PowerBook G4 Ti:
    1. Where can one look up the meaning of diagnostics codes? HDD diagnostics error code: ata1/6/3 HD:2,0
    2. What does a single blinking LED on the battery mean?
    3. AppleCare does not show the HDD, chance it is ok but not connected?

    A friend's system wouldn't start up, he said I could take a look, asking me to recover some family photos from his Hard Disk Drive. This machine had not been used for months. So far I have uncovered two issues and would be grateful to receive further guidance here to get this machine up and going. Please pardon me writing too much information.

    system specs
    PowerBook G4 500MHz 15" Titanium 20GB 512MB
    L2 cache: 1024K @ 250 MHz
    MLB serial #: QT1091PWKWMA
    AirPort card present, Boot ROM version: 4.1.8f5
    service history: 3/10/2005 = repaired directory errors, charged clock battery, installed optical drive.

    action: Remove PRAM battery and it powers up.
    I like to tinker, and I'm recently out of work, stumbled upon a place with step by step instructions to take apart at <http://homepage.mac.com/sysop/PhotoAlbum13.html>.
    Followed those steps and removed the persistent RAM (PRAM) battery, put it all back together ( except for a few screws, oops! ) and it powers up, and seems to be charging the battery as an LED lights up now. Took it apart again and checked Hard Disk Drive connections, appears ok. Put the PRAM battery back in ( battery shows: 616-0144-A, match to slide 35 ) and now the system boots ok. Maybe resetting the connections got things going, maybe the battery needed a kick, who knows.

    Explanation according to a few sources
    1. the PRAM battery will be used to power the system when no power supply is given and the battery is dead.
    2. the on/off button on the PowerBook is powered from the PRAM battery.
    3. the PRAM was designed to power the system for up to 2 minutes which is suggested to be long enough to change batteries to a fresh one.
    4. once the PRAM battery is dead one cannot turn on the PowerBook even if a fresh battery and AC power is connected :eek: , one has to disconnect the PRAM battery, turn on the system, then reconnect the PRAM battery so it can charge.

    How to find a replacement PRAM battery?
    The places to purchase these have not matched the shape of four circles stacked diagonally, nor have they matched the number of 616-0114-A. are these all pretty generic and interchangeable?

    Hard drive sounds
    Listening closely as the system boots without a CD disk in the drive I can faintly hear the HDD start to spin for 1/2 second but then stop. This pattern repeats maybe 20 times, spinning and stopping twice, then spinning and stopping six times.

    Screen display on normal bootup
    when powering up with no CD in the drive it shows a folder in the center of the screen, alternating between a question mark and a face.

    action: run Hardware Test, gives error code ata1/6/3 HD:2,0
    Now that it powers up, Run "Apple Hardware Test" for PowerBook SW version 1.1. While starting there is a vertical red stripe on the right 1/4 point.
    results of running the "Extended Test":
    AirPort = Passed
    Logic Board = Passed
    Mass Storage = Error detected
    ata1/6/3 HD:2,0

    Where do you find the lookup codes?
    Here I hit a wall, searched around for several hours and found no hits. Closest thing was an incorrect diagnostics message when multiple drives are in use.

    note: while writing this text I ran it again ( after five or six times over a week ) and it passed!? This was the first time running hardware test after running applecare. Ran applecare again which found no HDD, ran hardware test again and the same error came. :confused:

    action: run AppleCare Protection Plan 2.5.5, cannot find HDD
    Machine boots up to MAC OS 9.1, shows Red Battery next to clock
    TechTool Deluxe asks to "Select the volumes you wish to examine, then click 'Check.'" but there are no items to select from.
    Disk First Aid: shows only AppleCare Diagnostics AT API DVD-RAM, bus (Write Protected)
    Drive Setup: also shows only CD drive.

    If you have any advice or hints for these I would appreciate it.
    - get contents of hard drive
    - get PowerBook to run again
    - avoid this happening again

    thank you very much for any help, ;)
  2. sekitan macrumors newbie

    Mar 22, 2007
    saving data

    if the goal is to recover files on the HDD, perhaps using a 2.5 to 3.5 IDE adapter and slaving this drive in a desktop machine would let you access it. or perhaps there's a way to boot to a live linux CD like ubuntu for ppc? i've done this with windows machines. not sure about mac.

    apple does not provide their error codes to the public. sorry.
  3. epochblue macrumors 68000


    Aug 12, 2005
    Nashville, TN
    No lie...that might be the most helpful "help me" post I've ever seen. Most people just post "my comp broke - help" (or some slight variation). Thank you for being so thorough.

    Unfortunately, I have no idea what to tell you :(
  4. lazyboy922 macrumors 6502


    Dec 9, 2003
    Las Vegas, NV
    Lol! My thoughts exactly! Hope someone can help you out!
  5. FJ218700 macrumors 68000


    Mar 8, 2007
    Blue Dot, Red State
    does it boot into transfer mode (holding "T" when powering on)?

    what about when the "option" key is held on power-up, is your hard drive recognized.?

    on those Ti books, the hard drive basically just pops out once the rear panel is removed. IF you had another OS X formatted startup drive they are usually interchangeable, at least it would tell you if it is just the drive or a larger issue.
  6. tom.g.coleman thread starter macrumors newbie

    Mar 20, 2007
    Seattle, WA
    Update on attempts to fix


    - The system doesn't recognize the hard drive in all attempts

    - I have taken the drive out a few times, it would be a snap to replace. Haven't tried reading it from another device. Considering the external usb and other options as posted in other threads.

    Here's what it does when trying to power up:

    1. Nothing, just hit the power button:
    • power on sound comes
    • hard drive tries to spin up ( very faint sound )

      [*]faint rumbling alternates in how long it goes for
      [*]maybe it is trying to seek to the boot sector?
    • flashing blue globe appears in a white box
    • folder with flashing question mark appears, alternating with blue split face.
    2.Hold down the T Key :
    • power on sound comes
    • hard drive tries to spin up as before
    • screen stays dark
    3.How down the Option Key:
    • power on sound comes
    • hard drive tries to spin up as before
    • cursor shows as a wrist watch ticking for 90 seconds
    • screen displays two buttons

      [*]circular clockwise arrow,
      [*]arrow pointing right
    • press circular arrow

      [*]cursor shows as a wrist watch ticking for 30 seconds
      [*]arrow pointing right
    • press arrow pointing right

      [*]nothing happens
  7. FJ218700 macrumors 68000


    Mar 8, 2007
    Blue Dot, Red State
    right, so with the option key held on startup, the computer should post an image of the hard drive in between the two different arrow types (the circular arrow is restart and the righ arrow is proceed with startup). The compute is not recognizing a valid operating sytem on the drive. Starting in transfer mode should present a blue screen with the firewire symbol, but that should also requrie the drive neing recognized.

    Try one more thing, start the computer with the install disk in as before holding the option key. The comuputer shuld recognize the disk. If you select the disk image, then hit the icon with the "right-pointing" arrow key, you will procdeed to the install series. This will not erase the drive.

    When you get to the installer, go to the menu bar and choose disk utility. See if the hard drive is recognized. try to repair permissions (this will not erase it).

    If still no luck, but if the drive is indeed recognized, you can reinstall the system BUT BE SURE TO ARCHIVE THE EXISITING SYSTEM if you want to recover any files. (Check the install options)

    I have done this many times and it always works unless the drive is trashed.

    Just be careful not to reformat, or do a clean install when you're trying these steps.
  8. joeycavella macrumors newbie

    Nov 7, 2007
    Fixed my issue!

    Wow, tom.g.coleman, that was the most detailed help question I've ever seen and guess what? You fixed my problem! My G4 Ti sat around for a couple years and was dead. Power button completely unresponsive. Battery showed no lights when test button pushed. I disconnected the PRAM battery and to my amazement it started up with the power connected. Trying to reinstall system from disc right now. We'll see if this thing works but I'm just happy it turns on at all. Thank you! I hope you resolve your issue.
  9. archi penko macrumors member

    archi penko

    Nov 6, 2007
    eBay and ifixit.com generally have what u are looking for. I have a backup one jic from eBay. no way to tell if it still works after all this time not in use unless i install it tho.

    if you have a Powerbook 500 you can only interchange with the Powerbook 400 Mhz PRAM. Not any of the newer Powerbooks (667, 800, etc)

    the hard drive is not connected.

    the mac can't find what to do, where.

    Also means there is something wrong with the HD. I would,

    1) First, Make sure the IDE pin connector is pinned down and connected both to the Hard Drive and to the Logic Board - it should both be flat. Maybe something happened or shifted when you removed the PRAM. If nothing is out, i'd suggest "reseating" it. Disconnect and reconnect it.

    2) Second, Find a replacement IDE HD cable. see ifixit, etc.

    3) Third, Replace the HD - you may have a dead HD on your hands... i'd look to http://www.techrestore.com/

    After each step above, I would start up the comp just to check. if not, start up with the AHT CD.

    It's a lotta startups. Sux i know, but at least u are thorough.

    who woulda thought u could be sick of the apple startup chime... but you will, oh you will. muuaaahahahhaha.
  10. RedTomato macrumors 68040


    Mar 4, 2005
    .. London ..
    Most probably a dead HD.

    Try testing the HD in a different computer, or take it to an apple shop for testing.

    If you have access to another mac, easiest is to stick the HD in an 2.5'' external enclosure, and connect it to the mac and see if it is accessible.

    Note, many bus-powered 2.5'' enclosures don't supply enough power to start up some 2.5'' drives, so try to use an enclosure that is mains powered.

    That's the simplest thing to check, rather than fiddling about trying to replace laptop ribbon cables. Your HD is pretty old after all, it's had a long and good life.

    # What does a single blinking LED on the battery mean?

    Battery needs charging. Power is too low to wake up out of sleep or start up on battery power.

Share This Page