Powerbook Not powering up

Discussion in 'PowerPC Macs' started by -ASH-, Jun 5, 2012.

  1. -ASH- macrumors newbie

    Joined:
    Jun 5, 2012
    #1
    Hi Guy's..

    I have a powerbook G4 titanium and it fails to power on.

    Can someone offer me any advice??

    Following advice from other forums
    I have checked the power from the Pram battery and it's showing 3.8v
    I've reset the pram (using the reset button on the back), also pressed cmd, ctrl & shift).. and still with no luck.

    Can anyone please advise me on what to try next??

    Many thanks in advance.

    ASH
     
  2. Lil Chillbil macrumors 65816

    Lil Chillbil

    Joined:
    Jan 30, 2012
    Location:
    California
    #2
    have you tried checking the ram cards because I had a g4 tower 2 years ago that refused to power on so I looked inside and saw a half in half out ram card

    but what do I know that was most likely a fluke that I fixed it
     
  3. -ASH- thread starter macrumors newbie

    Joined:
    Jun 5, 2012
    #3
    Yes, I've checked the ram..

    I'm thinking that thee must be a fuse on the logic board that has blown but I'm unsure...
     
  4. Aameiel macrumors regular

    Aameiel

    Joined:
    Jan 22, 2011
    Location:
    Cape Coral, FL
    #4
    when u try to start it does it make any beeps ???
     

Share This Page