Powerbook will not power on after HD upgrade

Discussion in 'PowerPC Macs' started by milfredo, Mar 31, 2009.

  1. milfredo macrumors newbie

    May 20, 2008
    Hi Folks,

    I recently tried to upgrade my powerbook with a new HD (see http://forums.macrumors.com/showthread.php?t=677016) but forgot to format the drive before trying to install the operating system. I gave it another go last night but with the new disk installed and everything back in place, it would not power back up. I took it to bits again and checked everthing was connected including the little ribbon cable from the keyboard but still nothing. I put the old disk back in with the same results. there is no response from the power key at all. Everything is pushed home where it should be so I'm a lttle worried about what could have happened.
    What I did notice was that with no battery or power connected, I could hear a faint internal clicking that I guessed must have been getting it's power from the clock battery.

    Has anyone had this happen to them and what did they do to resolve it?

  2. clyde2801 macrumors 601


    Mar 6, 2008
    In the land of no hills and red dirt.
    That stinks. Have you tried booting off of the apple hardware test disk or your system restore disk?

Share This Page