Powerbook won't boot from Mac OS X Install DVD

Discussion in 'macOS' started by starfish, May 19, 2008.

  1. starfish macrumors newbie

    Joined:
    Nov 17, 2004
    Location:
    Sussex
    #1
    Hi,

    My powerbook 12" 1ghz, 768 MB RAM, (combo drive) won't boot from a new retail copy of Leopard (DVD). When I turn it on and hold down C on the keyboard, it takes a while but eventually just comes up with a no entry sign on a grey background.

    It does the same if I boot into the OS (10.3 Panther) and start the install process (press restart on the installation).

    It won't boot from my tiger retail backup DVD copy either, although it doesn't show the no entry sign it just keeps showing the grey loading background (I've left it for an hour and it still didn't load!). It boots fine from my panther retail cd's and my original grey 10.2 disc. It also plays dvd's fine.

    Any ideas?

    I really need to get this sorted as I have sold the laptop and need to clear it ready to dispatch!

    I've tried reseting the pram and nvram and set-defaults etc in open firmware too!

    Cheers

    Mike
     
  2. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #2
    Hmmmm, maybe a firmware update is needed for the laptop itself before it can run the newer OS installs?
     
  3. starfish thread starter macrumors newbie

    Joined:
    Nov 17, 2004
    Location:
    Sussex
    #3
    the thing thats annoying me is that I had this problem a long time ago, and I got round it but I can't for the life of me remember how!!

    up until a few days ago it was running tiger 10.4.11 but I can't remember how I installed that in the first place!

    where would I be able to source a firmware update?
     
  4. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #4
    Did you try a PMU reset?

    Also if you have another Mac, you can boot your pb in target disk mode, connect a firewire cable to the other Mac and install a fresh OS using the other Mac using its optical drive to read the installer DVD.
     
  5. starfish thread starter macrumors newbie

    Joined:
    Nov 17, 2004
    Location:
    Sussex
    #5
    just tried installing via target disk mode from my other powerbook and the install seemed to have worked.

    BUT when i disconnected the 15" powerbook from the 12" and booted the 12" i got the no entry sign on a grey background again.

    any ideas?
     
  6. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #6
    Ok, repeat your target disk mode steps. On your pb15, open Disk Utility and select the pb12 disk drive. Erase it (you can use options to do a secure erase if you are so inclined) using the OSX extended/journaled setting.

    Then insert the installer DVD in the pb15 and start the install. Select the pb12 drive to install on and do a fresh install. Once the install is completed, first unmount the pb12 drive from the pb15 finder. Then hold the power key on the pb12 down until it shuts off. Disconnect the firewire cable and try to start up the pb12.
     
  7. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #7
    One thing I forgot...

    When the pb12 disk is mounted on the pb15, select it and do a Get Info on it. Make sure (at the bottom of the window) that "ignore ownership on this disk" is NOT checked. After you erase it and before the install, do it again.
     

Share This Page