powerbook won't boot up

Discussion in 'PowerPC Macs' started by jacksplat, Jun 20, 2006.

  1. jacksplat macrumors newbie

    Jun 20, 2006
    I picked up this 12" powerbook 867mhz saturday second hand, and it worked great for 2 days. Sunday night I shut it down completely because I knew I wasn't going to be using it until I returned home from work last night (monday). So I get home, turn it on, get in to OSX (10.3 not sure what rev after that) and i start setting up my wireless when the mouse freezes. So i did a hard reboot, get to the login and the mouse is still frozen. So i did another hard reboot, this time i got to the grey screen with the apple and the spinning icon, but it hangs, and thats as far as I can get, still. I tried resetting the pram and the pmu and the open firmware, none worked. I finally booted off the 10.3 cd and ran the disk utility, it found errors and after running "fix" a few times, it looked like everything was fixed, but it still wouldn't boot. I took out the extra memory stick, but that didn't work either. So, i've been talking to people on IRC and searching Google, but I can't find anything else new to try. How do I fix this? This is not really turning out to be the wonderful first time Mac experience I had hoped for.
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Since it's second hand, I'd reinstall the operating system to give you a clean start. If there's information on the machine that you can't afford to delete, then do an Archive & Install so it'll hopefully be set aside safely. :)

Share This Page