powerbook won't recognize it's original HD now that it's in an exterior case

Discussion in 'PowerPC Macs' started by wastingmytime, Jan 10, 2008.

  1. wastingmytime macrumors newbie

    Jan 9, 2008
    What have I done wrong!

    I replaced my hard drive and everything worked great for a day or two, I could transfer data off the old60 onto the new 120HD via the firewire enclosure. I have a Tibook G4, need more space. then my pictures wouldn't load on the exterior, i've been days trolling the internet for answers, like 25 hours now. And now suddenly it can't get itunes open either. I did nothing!

    i can go into the finder, navigate to my old itunes which shows that it's there (it's 7.1) and when i open it, it opens itunes4 off the new internal drive (fresh install of OSX had not been upgraded yet). (and the songs i had imported off CDs fresh into itunes4 on the new drive are gone as well, it's empty.)

    same with iphoto, if i can get it to open at all, it ends up opening the application off the new drive and other aps won;t work now as well.

    today i changed the home name to see if that helped (it was just left the same as the old homefolder name, thought that might explain the confusion) no change.

    iphoto says it won't load, sometimes says it needs to be updated, or says files missing. (i did drag pictures and 3 .avi's off from the library that first day) or opens the new drive's copy of iphoto. itunes opens the new drive's version, and songs i imported fresh are now missing, but were there two days ago. this problem start about 5 days ago.

    i reformatted the empty drive, as per instructions, when installing. was i supposed to change user names or passwords or not drag files across to the new drive?

    so many questions...such a huge waste of time. pretty miserable at this stage. http://images.macrumors.com/vb/images/smilies/frown.gif
  2. pulsewidth947 macrumors 65816


    Jan 25, 2005
    Firstly I understand how frustrating this can be, but don't worry its probably a simple solution!

    Ok - so let me get my head round this. You've swapped out the hds and now you have a 120 GB internal, and you've stuck the original 60 GB in a firewire enclosure?

    Cool. So when you did a fresh install on your new 120 internal, did you choose to use user migration and copy all your settings and stuff over firewire? If not give that a go, and report back.

    :EDIT: oh I presume you've done the usual repair permissions?
  3. wastingmytime thread starter macrumors newbie

    Jan 9, 2008

    the problem was confounded by changing the name of my home location. apparantly this is a mac nono, unless logged in as a root user. i took it to a shop today, because i couldn't figure it out after hours of forum searching. problems have been sorted out, thanks for your concrete suggestion. part of the problem was that after the clean install I moved applications around by dragging them, not knowing i had to create new libraries and aliases to get between them.
    i couldn't copy everything at once because i had some applications that didn't function on the old drive and wouldn't delete, even after i tried to chase down and delete their accompanying libraries and extra documents that accompanied their original installation.
  4. pulsewidth947 macrumors 65816


    Jan 25, 2005
    Glad you got it sorted! Yeah renaming your home folder is a recipe for disaster unless you know what you are doing. I presumed you knew this, but all is well that ends well!

Share This Page