Powerbook Won't sleep

Discussion in 'Macintosh Computers' started by EJBasile, May 18, 2005.

  1. EJBasile macrumors 65816


    Apr 20, 2004

    My powerbook won't go to sleep automatically (when plugged in and when running on battery). Instead the screen just turns off. I have waited 15 min for it to turn off but it won't do it. I changed the sleep settings and it still will not work.

    Whats going on here.
  2. mumblingmynah macrumors newbie

    May 25, 2005
    Mine will not go to sleep either, even if I close the lid or manually select sleep from the apple menu. It attempts to go to sleep--the display switches off, the sleep light pulsates once--and then it immediately wakes up again. I'm not sure how long this has been going on, but it may be since I installed Tiger. This is really worrying me, because a couple of times I have shut the lid and walked away for a few hours, not realizing that it was staying awake and running.
  3. tekmoe macrumors 68000

    Feb 12, 2005
    Try rebooting your Powerbook. After it reboots and you are back at the desktop, put the Powerbook to sleep. If it sleeps, it's probably an application that is causing it to hang. If it still will not sleep, you may have a process that runs on startup, in which you will need to check under Accounts in System Profiler.
  4. mumblingmynah macrumors newbie

    May 25, 2005
    I've already tried rebooting, thanks. I have also tried disabling all startup items, uninstalling some third party apps I was unsure about, watching the activity monitor for anything unusual, repairing permissions with disk utility, and resetting the PRAM. About the only thing I haven't tried is reinstalling the OS, which I really don't want to do. I was on the phone with an Apple technician for a while, and they were no help either.

    The only helpful thing is that I've discovered that I can put my powerbook to sleep by unplugging the power and then closing the lid. Unplugging the power and selecting sleep from the menu still doesn't work. I thought this might indicate some problem with the energy saver settings for the AC adapter, but no luck there either.
  5. xinxin macrumors member

    Apr 13, 2005
    Melbourne, Australia
    SMTP service caused inable sleep

    smtp so far is the only one that I heard could cause sleep not working. I am sure there is a setting in os x you need to specify sleep behaviour. You have to edit a config file like doing in unix.

    Sorry I can't remember what it is but google it hope you find the answer.
  6. dollystereo macrumors 6502a


    Oct 6, 2004

Share This Page