Powerbook's hard drive won't mount

Discussion in 'Macintosh Computers' started by Mike Teezie, Mar 21, 2005.

  1. Mike Teezie macrumors 68020

    Mike Teezie

    Nov 20, 2002
    My friend's Powerbook started going into kernal panic the other day on boot up. We aren't sure why or how, so he's sending it back to apple for repairs. Yes, we tried all the usual things to try and get it back in working order again Zapped PRAM, reset Power Manager, all that. Even tried to reintall OS X.

    So it's going back to Apple. The guy at Apple told us to get anything off the hard drive he might need, and we are in the process of trying to do that. I have the Powerbook connected to my G5 with a FW400 cable.

    The problem is, it won't show up on my desktop as a mountable drive. I looked in system profiler, and it shows the Powerbook as being on the Firewire bus. But like I said, no icon on the desktop, or anywhere else.

    Might I be doing something wrong? I'm trying to help him out, as it goes back to Apple in the morning, and he has some stuff for his classes on the Powerbook.

    Any ideas?

Share This Page