Powercolor AX4890 1GBD5-PPH on MacPro 1.1 - Not working help!

Discussion in 'Mac Pro' started by kronoss, Nov 5, 2009.

  1. kronoss macrumors newbie

    Joined:
    Apr 3, 2009
    #1
    I just got the Powercolor HD 4890 1GB GDDR5

    Installed Natit
    Shutdown
    Remove old 1900xt, installed new Powercolor in slot
    Booted, Blank screen, hard drive seemed to work, and load the OS, then nothing happened.
    I shutdown from the button, put the monitor in the different DVI slot, hard drive booted the OS (still blank screen), then went in a loop of rebooting every ~30 sec (could hear chime).

    What should i do ?


    I tried to flash using the DOS atiflash on the pc. and i got

    SSID Mismatched
    OLD SSID: 2282
    New SSID: 8030

    I put the card in my PC, and it works fine, but on my Mac Pro 1.1, still no luck.


    Here are pics of the video card

    [​IMG]
    [​IMG]

    it seems that newegg sent me the wrong card.

    Item Number: Item Description: Quantity: Price:
    N82E16814131152 VGA POWERCOLOR | AX4890 1GBD5-UH R 1 189.99

    Instead of
    AX4890 1GBD5-UH they sent me
    AX4890 1GBD5-PPH ,

    can i make this card work ?
     
  2. dsiew81 macrumors member

    Joined:
    Jun 29, 2007
    #2
    Check the 4890 threads. Info is all there.
     
  3. kronoss thread starter macrumors newbie

    Joined:
    Apr 3, 2009
    #3
    i searched, but could not find anything on this version
     
  4. Tutor, Nov 6, 2009
    Last edited: Aug 29, 2011

Share This Page