PowerMac 8600 + Imperialism

Discussion in 'Mac and PC Games' started by x30n, May 11, 2008.

  1. x30n macrumors newbie

    Joined:
    Apr 17, 2007
    #1
    Hi!

    I have some trouble playing Imperialism (one, not two), on a PowerMac 8600. I seem to remember, that I had this problem on a Performa 5200 a loooong time ago as well.

    The game offers an overview about the military units stationed in a city in form of a book. This overview can also be used to upgrade the units as soon as newer units are available. However if I try to open a "page" which contains units that could be upgraded the computer crashes.

    I first tried it with Mac OS 9.1. As soon as the problem appeared I installed 7.5.3 as well which gives me at least an error code when it crashes. Error Code 11, which means "miscellaneous hardware exception error".

    The PM is equipped with a G3 400MHz (Sonnet) CPU, 512MB RAM, 2x HDD and all the usual crap. I tried it with the original PPC 604 CPU as well, without any success.

    I know that I actually used the update functionality when I was playing the game ages ago. But I don't know what I needed to do to fix it. Any tips?

    cu
    x30n
     
  2. Eric5h5 macrumors 68020

    Joined:
    Dec 9, 2004
    #2
    Works in Classic mode (OS 9.2.2) on OS X, minus the CD music. Make sure it's the latest version (1.1.7), which is actually still available on the website from whatever company has the rights to it now, or at least it was when I played this about 6 months ago.

    --Eric
     
  3. x30n thread starter macrumors newbie

    Joined:
    Apr 17, 2007
    #3
    Hello,

    thanks for the information, it really helped me. I found the Mac Patch for Imperialism on the Ubisoft Website.

    However when I try to run the new binary, it doesn't start. All I get is an error message which tells me exactly: "Could not complete your request because ." (no I didn't forget anything). I copied the resource file as well. The same problem happens on the 8600, my G5 and PB G4 (with classic environment). They all have the same crash problem as well.

    Maybe it doesn't work with the german version. I have the german retail version (with box and everything ...). I found some full versions on several websites as well as on bittorrent. Looks like nobody cares for the copyright any longer. Unfortunately all the versions I found where for Windows.

    Does anyone know a source for the english version? Maybe that would solve the problem.

    cu
    x30n
     
  4. Eric5h5 macrumors 68020

    Joined:
    Dec 9, 2004
    #4
    Could be; never had any crash problems myself with the English version.

    eBay...at least that's where I got mine (still shrink-wrapped, even!). not exactly common though.

    --Eric
     
  5. x30n thread starter macrumors newbie

    Joined:
    Apr 17, 2007
    #5
    I just confirmed that it must be the german version i have here. On my Linux box I was able to set up a Windows in a box (very strange system that ... :confused: ). However I couldn't patch my windows version as well. Than I tried it with the US Version I found on BT, and it worked fine. However, windows 95 is not exactly my idea of a gaming setup so if anybody would be willing to supply his Imp Folder to me please contact me via PM.

    cu
    x30n
     
  6. bosequo macrumors newbie

    Joined:
    Jul 5, 2008
    #6
    Same goes for me.

    I finally found my old version of Imperialism after shifting heaps and piles and stacks of files and crap. Now I have the very same problem: The German version does not work. It just doesn't. Somebody doesn't seem to like us...

    Would anybody care to send me his 'Imperialism'- Folder? Contact me via PM? Working towards the understanding among nations?

    Thanks:
    bosequo
     

Share This Page